SimScale CAE Forum

My mesh failed

My project says this error: The Mesh failed. Therefore, the simulation run did not start. You can find information about the Mesh failure in the Mesh section of the Navigation tree.

Please help if you can.
Here is the link to my project: https://www.simscale.com/workbench/?pid=3636301971435775223&mi=run%3A16%2Csimulation%3A12&mt=SIMULATION_RUN

This is my 3rd run and this is what it says: The following mesh operation(s) failed:

  • Copy of Mesh 3
    • The meshing failed due to a self intersection in the mesh on the following entities: face16914@solid1, face24032@solid1. The exact position is printed at the end of the Meshing Log.

Please check the ‘Event Log’ and ‘Meshing log’ for more details. In case of questions, feel free to contact us at support@simscale.com or ask in the Forum.

Hi!

Could you provide more insights about what you are trying to achieve with this simulation? Are you looking to simulate internal or external flow? I can’t tell from the current boundary conditions.

The current CAD model is definitely not very clean, which can cause some problems with self-intersections (which is the error that you faced in the meshing operation):

For CAD models that are dirty, usually the hex-dominant meshes work better, as they have their own mechanisms for filtering out very dirty sections.

Can you clean up the model for me?

First of all, I am very new to this and have no experience so I might not understand some of the terms you are typing. Secondly, I do not know where the CAD tool is so, can you completely clean up my model or tell me how to clean it up? Also, I think I am looking for external flow as in air pushing against the train from outside.

Thank you,
Akshat.

Hi,

This model is quite challenging for a first simulation. If you are very new to SimScale (and to simulations in general), I would highly recommend that you have a look at the available step-by-step tutorials, which will give you a good overview of a simulation with SimScale.

In fact, a few of them are related to external aerodynamics:

As far as CAD goes, interacting with .stl geometries can be very troublesome. Usually the best way to clean up a .stl file is with the same tool (and preferrably the same person) who generated the original file.

If you’d like to explore additional geometries, feel free to browse through the public projects section, searching for train geometries. There should be a handful of them if you check some of the listed projects.

Cheers

1 Like

Hey jousefm,

I’m a studying mechanical engineering and I’m doing a study on a f1 rear wing. When I start the simulation I have this error:
“o The meshing failed due to a self intersection in the mesh on the following
entities: edge3173@Flow region, face13870@Flow region. The exact
position is printed at the end of the Meshing Log. ca
href=“https://www.simscale.com/knowledge-base/intersections-in-model/’
target=”_blank”>Learn"

I hope you can help me.

Project: https://www.simscale.com/workbench/?pid=2823938705486073439&mi=spec%3Affb311ad-b2d8-47b0-b08a-3e14ff70bd9c%2Cservice%3ASIMULATION%2Cstrategy%3A21

Hi!

You are having some CAD issues, since the CAD model contains some very small faces. More especifically, around these coordinates (which are available at the end of the failed mesh’s meshing log):

Up-close:

Naturally, modifying the CAD model around this region to make it cleaner is an option. Alternatively, you can also adjust a “Small feature suppression” to make the meshing tool ignore the small face.

In your case, a value of 1e-4 should be a good starting point.

Cheers

Hey, thank you very much for the response. Meanwhile I tried your suggestion and didn’t work, I also tried to analise only the wing and not the region that was causing the problem and it show me the same error.
Do you have another suggestion? I can’t modify the model because I download it from grabcad and it doesn’t let me change that part of the wing.

Thank you

Hi,

I tried meshing the model yesterday with the changes that I mentioned and it worked - so you likely changed something else in the mesh setup.

In any case, I just had a look at your project and it looks like you have a successful mesh. Have you been able to overcome the problem in the meantime?

Cheers

Meanwhile I changed the parameter “Gap refinement factor” to 0.005 and only select one part of the wing
I’m running a simulation right now lets see what I get.

Thanks one more time, I will keep you updated

So it kinda worked but the results about the velocity isn’t showing!

Don’t know what is going on.

The solid walls receive a no-slip condition for velocity (i.e. velocity = 0).

I’d suggest that you have a look at our post-processing tutorial for CFD simulations, so you get familiar with the filters. From your description, you are likely looking for a particle trace filter.

Cheers