SimScale CAE Forum

Decrease CFL number

There is some issue with CFL number
I am trying so many things to decrease CFL number even see many posts on the forum but still, I can not catch my fault
It is 0.850m rocket model wind tunnel testing with some different velocity in Compressible flow
this is the project link
https://www.simscale.com/workbench/?pid=6312484841509898958&mi=spec%3A62c3d3fd-5c5b-451c-b384-925cc82ab523%2Cservice%3ASIMULATION%2Cstrategy%3A8

Hi @sreman!

I saw that you made some progress and figured out the issue by yourself?

Best,

Jousef

no @jousefm issue is about CFL number.
but now it is solved but still, I did not get the right approach to resolve that issue
If you have any proper approach to solve that issue which is shown in the project snapshot so please share with me :blush:
thanks for your response @jousefm

Always check the documentation if you are interested for more information on a particular topic :slight_smile: Maybe this helps: https://www.simscale.com/knowledge-base/what-is-a-courant-number/

Enjoy your weekend!

Jousef

thanks @jousefm

The flow domain is too small to solve such a problem. Usually, in external flow problems, you should consider ensuring the upstream and downstream is large enough to capture the flow physics. As an example, if the characteristic length is L, you may consider the upstream length to be 10xL and downstream to be 30xL.

  • Check the literature and find a suitable flow domain for external compressible flow problems. Extend the upstream and downstream accordingly.

Adjust the mesh settings, to make the cells “cubic”

The simulation type in the link you shared is a steady-state one. It is not transient, therefore the end time and delta t are not really the time, but the iteration settings.
image

To perform a transient simulation, switch to transient:
image

Please check the tutorials before doing any of those, because you will find out that there are still much to do. Transient simulations are not that easy. You may like to start from a steady-state simulation to get familiar with the solver.

Thanks for the response @mehmet_oezcan
I also searching so many things on simulation control but still, I have doubt about what you say in the explanation that therefore the end time and delta t are not really the time, but the iteration settings.

This is what “End time” and “timestep” defines in a Steady-state simulation:

hello @mehmet_oezcan as you said that set-upstream 10L (8.5m) and downstream 30L(25.5) and I also set Bounding box resolution according to length so that the cells are cubic but there is a occurs error to see in snapshots

Maybe the Bounding box resolution is too high so that I found this error
Can you tell me the solution
Thank you

You can find the answer to such questions in SimScale documentation: Error: Out of Memory

The message says the number of elements is too many to execute this job.

I recommend to check the tutorial section:

Standard

Hex-dominant

Hex-dominant parametric

1 Like

Thank you @mehmet_oezcan for passing information.:smiley:

1 Like