SimScale CAE Forum

Problem with Surface refinement with Cell Zone


#1

Hi, my name is Antonio Targat, and I am having problems to mesh a geometry in SimScale. For some reason, I am not able to Mesh any geometries that contain Surface refinement with cell zones.

  • I am trying to Mesh three MRFs Zones and a porous zone within our geometry, in order to simulate rotating tires and fans, and Radiators respectively.
  • The Mesh operation fails within a couple of minutes of run-time with the following error message: A cell zone has been defined with assignments of faces. This is not supported. Please create a closed solid region that exactly represents your cell zone in your CAD tool.
    I already checked all of our solids for holes, and they all seem to be closed. An alternative MRF geometry was also constructed by using a boolean operation, as suggested by @ anirudh2821998 on the forum Issue with assigning mesh as the domain, which was also unsuccessful.
    I even tried to generate the STLs of the geometry in both CATIA and in Solidworks, with no success whatsoever.
    In my latest attempt, I tried Meshing an already generated Mesh with the same MRFs, which didn’t work.
  • Here is the link to the project: https://www.simscale.com/projects/leon_schmidtke/emc20_pre_season/
    Thank you.

#2

Hi @leon_schmidtke,
Here is the main reason of your mesh failure, you have assigned only 1 face for the surface refinement instead of assigning the volume to the surface refinement with cell zone option ON. Try again with the new assignments.

Cheers
Hamza Baig


#3

Hi @HamzaBaig ,
I’ve been messing around with our Geometry and I think the problem is that I can’t really upload a .STL geometry with of multiple solids or volumes. Somehow I can only upload them as an assembly of multiple faces, which in turn can’t get meshed with Cell Zones. I’ve been using a script that SimScale sent to our team a couple of Years ago to merge the STLs from all components into one single STL (https://drive.google.com/file/d/1t8zTQIJ_WU6-b7FWn2EqtNuMcbVqmJ7L/view?usp=sharing). Do you guys have any other approach to merging STL Files?
Thank you in advance,
Antonio Targat


#4

@leon_schmidtke: You can merge STL (text) files by hand, using a text editor (like Notepad++). I discussed it here : Forum topic on boundary layer


#5

Also check out the files here: Merging STL files - cheers!

Jousef


#6

Hi there,

I see dozens of geometries and models, so I’ll just be focusing on the latest one, and just a couple comment for the moment.

First check should be to have a domain with proper dimensions so that the splitting generates perfect cubes.

image

In your case, the bounding box dimensions are 27.825 x 7.192 x 7.2 m3. I would suggest to define the boundaries so that you have a bounding box of dimensions 25 x 7.2 x 7.2 m3. This should work with your current resolution (105, 30, 30) to get you cells of 0.24 m at refinement level 0.

I would avoid having the MRF cylinder so close parallel to the wall of the model. Either cleanly intersect the geometry or leave some room.

In this latest mesh, I can’t see the number of cells in the log file. But in one of the previous meshes, without the colling refiment you were already over 20 million. Maybe start with a slightly coarser mesh.

I’ll see if I can have a closer look this weekend.

Cheers,


#7

Hi @jousefm @Retsam
I tried merging the STL Files both manually and with the scripts that are here: Merging STL files ; and I still get an assembly of faces instead of an assembly of solids as result. I even checked the code of the files after both scripts ran and everything looks fine.

All solids are listed on the file, and they all start and end as I think they should…
In one of my uploads ( https://www.simscale.com/workbench/?pid=2840410787042819858&mi=geometry%3A175&mt=GEOMETRY) I somehow managed to upload two separate solids, but when I repeat the process using the full car geometry the same assembly of surfaces appears.
Do you guys have any other suggestions?
Thank you in advance,
Antonio Targat


#8

I’m having the exact same issue with my MRF zone not showing up as a solid, but rather a face and therefore not being able to create a cell zone within it. Here’s the link to my project: https://www.simscale.com/workbench/?pid=4446088511264372014&mi=spec%3A1a2e994f-3212-423b-b325-0e70174224f5%2Cservice%3AMESHING%2Cstrategy%3A20&ps=algorithm%2FFullSnappyHexMesh--oneOf%2Frefinements%2F6&sh=2

I was able to get an MRF zone that was a face to work last year with this project (in the UT 16 section): https://www.simscale.com/workbench/?pid=5893466710854457412&mi=spec%3A283aa552-dd48-4e4c-a7eb-458d179196f1%2Cservice%3AMESHING%2Cstrategy%3A48&ps=algorithm%2FFullSnappyHexMesh--oneOf%2Frefinements%2F8&sh=12 but for some reason the same method of defining a cell zone on an MRF is no longer working.

I’m also using an STL merging script.

Thanks in advance.


#9

Hi Wrenda,

I just want to add that we are having the same exact problem and also have the experiece, that last year we could use MRF zones on a face. The problem even arises on last years models that have proven meshes. The only difference between us, seems to be that I am not using a merger and have merged them all manually to make sure there are no errors. Hopefully this gets resolved soon.

Best Regards,
Jonas


#10

@jousefm I am also having this same problem where MRF zone faces were acceptable last year and are now not working. Can you please explain a fix to this problem? I need to know specifically how to change either the CAD model, STL merging, or selection process within simscale so that a solid body that should be an MRF zone is selected as a volume and not a face.

Thank you!

Dan


#11

@jousefm first all thank you for time and attention. I have been reading several forums with regards to this issue and I would like to know whether a new alternative has been proposed to define the refinement with Cell Zone. At this moment I am stuck trying to introduce the porous media approach in our car’s radiator due to this issue. As it is no longer the same as what was explained in the tutorials, could you please give us the correct approach?

Thank you again!

Alejandro


#12

Hi Alejandro!

The issue has been discussed here: Meshing Fail: Cell Zones Assigned Using Faces , not sure if you have already seen it but maybe it helps. If not, please tell us what is unclear and also answer in the mentioned post to keep things organised. Will jump in once you need help!

Best,

Jousef