SimScale CAE Forum

Meshing Fail: Cell Zones Assigned Using Faces


#1

Hi,

I am running a model of our potential car and am having some meshing issues. I can’t seem to be creating the cell zones as per the tutorial because it says the mesh zones are selected using faces. I have not had this problem before. How can I solve the error? mesh%20error

project link: https://www.simscale.com/workbench/?pid=2684886202805026125&mi=spec%3A008af424-8b81-43e5-9afb-2ba41f617996%2Cservice%3ASIMULATION%2Cstrategy%3A1

Best,
Tina


#2

Hey @tinaalim,
i have looked in your older simulations, and there i noticed the following.
The front_cylinder is a volume, and you pick it to mesh it with the cell zone.


In your current simulation, you try to pick a face.

And according to the errormessage its not supported.

I think you have to change your geometry.

Best regards
Kai


#3

@Kai_himself I have been having the same problem with MRF zones being picked up with a face selection and not a volume. How do you select a solid body so that it is recognized as a volume in simscale? I believe this will solve the MRF zone problem.

Thanks,

Dan


#4

I haven’t done anything new in terms of how I have created the geometry for my selections to change. Do you have any idea why this has happened? Also, the webinar tutorial does the same thing as me and they are able to get results. why is that?
Webinar link: https://www.youtube.com/watch?v=l3tZuv-x8tw
@ 1:07:44 mark


#5

@tinaalim Simscale definitely changed something on their end so that MRF zones need to be selected as volumes and not faces. I have also been trying to get this resolved but havent gotten a response yet. Last year all MRF zone simulations were accepted with faces … now they are not.

Dan


#6

But stl files turn everything into faces anyways, so I don’t know how to remedy this! I managed to get volumes on a previous geometry, but that was just sheer luck and not due to anything I had changed with creating the files or meshing them.

Tina


#7

I really dont know either thats why im waiting for a response.

Dan


#9

I am having the exact same issue, and I’m using the model that is used in the Webinar. I’m hoping for updates (:


#10

@jousefm Any insight on this?

Tina


#11

Hey guys!

Will reach out to the meshing team and get back to you as soon as possible :slight_smile:

Update: Only Volumes are allowed!

Best,

Jousef


#12

Hey any news on this? Ive been waiting to do simulations.

Dan


#13

Hi Dan!

Only volumes can be selected :slight_smile:

Best,

Jousef


#14

Yes I have been aware of this for quite a while. I think what everyone has been wanting to know is HOW to get a volume selection in simscale. When the STL is imported only solid bodies are created and when the MRF zone solid body is selected either in the tree pane or by clicking on the solid, it is always slected as a face.

I have also already tried to click on the “select volume” button on the top toolbar but this does not work.

Does the CAD Geometry need to be changed for it to be accepted as a volume?
Does the STL Data need to be changed?
Am i just not selecting the solid body correctly?

Any help would be appreciated. Maybe add screenshots for other users to follow.

Thanks,

Dan


#15

Hi Dan!

We will soon release cell zones for the new standard mesher - you should then get rid of this problem. Regarding the volume selection you can share the project that is affected in your case and I will have a look at that.

Cheers,

Jousef


#16

https://www.simscale.com/workbench/?pid=3437970283570097560&mi=spec%3A1d446c0a-9489-404a-929c-2f0728e3dcb9%2Cservice%3ASIMULATION%2Cstrategy%3A2

Here is the link.

As i had said, selecting the MRF Front Left results in a face selection.

Selecting the volume tool first does not fix the problem. This only selects the whole car solid body


#17

Hi Jousef,

When do you think the issue will be resolved? Because as you know all our FS deadlines are very tight.

Also this is the link to my project that I am struggling with like Dan:
https://www.simscale.com/workbench/?pid=2684886202805026125&mi=geometry%3A3&mt=GEOMETRY

Best,
Tina


#18

Will get back to you as soon as possible guys, let me check with the CAD engineers.

Best,

Jousef


#19

I believe i have stumbled upon the answer to the volume question, although i wasnt attempting to solve it.

I was trying to do some quick meshing to see the effects of different boundy layer settings (i want to have a good representation of the Y+ value between 30 and 300) and i used the merging script provided by simscale as this saves a lot of time. The merging script just throws all the STLs together but creates a 3D object file as the output shown below.
image

Normally i merge everything by hand in notepad so all files are saved as TXT files, which i believe converts the face selections to solid bodies. This is shown in the next picture where i merged everything manually and the drop down menu for each entity in the tree is now gone.

This can be seen under the highlighted MRF zone in the picture. This object is recognized as three faces, which, when combined are classified as a volume. This is shown in the next picture.

The MRF zone is now classified as a volume. In the next picture, it is shown with tire removed, that these three faces are:

  1. the front side of the cylinder in red
  2. the depth of the MRF cylinder in blue
  3. (Not shown) the other side of the cylinder

these three faces when selected together create the volume that is needed to have a functioning MRF zone (so i hope)

I will be doing a simple mesh now to confirm this.

Hope this helps

Dan


#20

Would be very happy to know Dan - keep us updated.

Something we definitely changed is that cell zones are not allowed on sheet bodies anymore, so it needs to be a closed surface. (@tinaalim & @dschroeder)

Best,

Jousef


#21

My geometry includes closed surfaces and no sheet bodies, but the error is generated because the solver refuses to generate mesh zones using faces. What can I do?