Blade Turbine Simulation with MRF region

In my project I am trying to run the fluid flow simulation for this proposed design of 3 blade turbine. The process is pretty straight forward but I seem to be misunderstanding some of the basic methods such as the “rotating zone”. The designs I have tested are requiring for it to be enclosed in a complete solid body but it gives meshing errors.

Here is a link to my project, I have made other test designs to satisfy the simulation needs i.e. enclosed the blades inside a cylindrical solid body.

here is a current meshing error for this geometry.

here is the blade inside the pipe to be tested.
I have been trying to run a proper simulation for this for a few days with no success. Would greatly appreciate some professional help on this.


Hi there, have a look at the following page that explains how the geometry should be prepared in order to run a simulation with an MRF region:

This one describes how to set the case: Rotating Zones | Advanced Concepts | SimScale
Finally , you can check this recent troubleshooting post:
Blade model disappear when assigning enclosure - #9 by tsite

Best regards,

I don’t understand one concept on making the CAD model for the rotating zones. Do the turbine blades I am simulating need to be inside a solid cylindrical body? If so the it will be imported in the simscale geometry as a single body. Please clarify. Thanks.

1 Like


Here are the rules for constructing MRF rotating zones:

  • There should be 2 volumes in the geometry: a flow region, and a MRF rotating zone
  • In your case , the MRF rotating zone would be a simple cylinder (a plain cylinder extrusion with 3 faces, fully solid, fully interfering with the flow region)
  • The solid blades should not be in the CAD model - they will cause multi-region mesh errors

Currently, the geometry consists of:

  • An incomplete flow region (there is a void in the middle of the domain):

  • In the geometry, “solid2” represents the solid blades, which is not correct. The blades should not be in the geometry - only the negative representation of them

  • There is no MRF rotating zone volume

The most simple way for you to fix this in CAD would be:

  • Make a brand new flow region, with a simple extrusion of a cylinder (i.e. a 3 faces cylinder)
  • Run a boolean/combine operation, to remove “solid2” from the newly created flow region. This will create a negative representation of the blades
  • Construct a MRF zone as a simple, 3-faces-cylinder
  • Delete the “solid1” from the geometry

At this point you should have the 2 necessary volumes only: a flow region, and a rotating zone.



Thanks for this insightful response. I will redesign my geometry and upload again.
Still one doubt about the rotating zone for the blades after uploading the geometry. I will check after importing it. Thanks again.

Hello Sir, I have developed the CAD model of the design as you instructed but now the cylindrical body isn’t being considered as a flow volume.

Here is a link to my new design. I understand the geometry is simple and I have read the following documentation,

but I’m not sure if the model requires me to upload a hollow cylindrical volume here.
Would be grateful for the help.

Hi there, your current model looks just fine, proceed to the following steps:

  1. Deactivate the ‘physics-based meshing’ option in the mesh tab
  2. Set solid 1 as a Cell zone

Check my mesh here:

Keep in mind that no-slip walls means that the domain is modeled as a solid boundary.

Best regards,


It runs pretty fine. Thank you so much @tsite and @Ricardopg for your help. Highly satisfied with the support. :blue_heart: