SimScale CAE Forum

Blade model disappear when assigning enclosure

https://www.simscale.com/workbench/?pid=2003932574751838362&mi=spec%3A08c85a40-4803-40d3-8b06-3cf01781b71e%2Cservice%3ASIMULATION%2Cstrategy%3A22&ps=domain

I am trying to make a rotating CFD simulation for vertical axis wind turbine. When assigning the enclosure I find that the blades of the turbine disappear and only the rotating region can be observed. The geometry also is automatically defined as one volume which is the flow region (see the picture below).

What I want my geometry looks like is as the picture below (which I got from the Propeller Study in Simscale Youtube video tutorial).

Can you help me to adjust my geometry so that it is the same as the ones in the Propeller Study?

Hi there, you can try to create your Enclosure in your CAD assembly too, import it to SImScale, and then use our CAD mode to subtract the fins from it, does it make sense?

Best regards,
Fillia

Does that mean I don’t need the fins for the CFD simulation?

Exactly, they should be removed from the Enclosure, and leave a void behind (the MRF cylinder should stay intact though).

Okay, I understand now. Thank you so much!

1 Like

SimScale Workbench

I’m trying to assign the MRF rotating zone but there is only one volume which is the flow region so I cannot select the cylinder. How do I make the MRF cylinder stay intact when assigning the enclosure.

Can you send me a screenshot please? :slight_smile:

Here is the screenshot, I also included the link to my workbench on my previous post.

I see, I think I might not have been clear in my previous messages, so I will write the process again:

Right not you have two parts in your CAD model:

  1. The MRF region cylinder
  2. The rotating blades

In your CAD software (not in SimScale) add a third part, which will represent the domain.

Upload your model to SimScale and enter the CAD mode. Then use the Subtract feature to remove the rotating blades from the Domain (only the domain, do not include the MRF region in this process).

At the end you should have the correct flow region, that will be void where the fins once were placed, and the intact MRF region.

Best regards,
Fillia

1 Like

When I want to create the mesh, why does it said that my simulation setup is not valid?

https://www.simscale.com/workbench/?pid=7723123031790411345&mi=spec%3A941866ca-bbf2-4a37-920d-701f7fae2582%2Cservice%3AMESHING%2Cstrategy%3A4&sh=3

Probably because you have not set the MRF region as a cell zone during the Mesh setup. Please have a look here, this explains the procedure: Rotating Zones | Advanced Concepts | SimScale Documentation

Dear @tsite,

I’ve disabled the physics based meshing and defined the rotating zone as a cell zone but it still give me the same warning.

I also want to set the result control for force and moment. Is it valid if I assign the force and moment at the surface of the rotating zone?

Hi!

The CAD model is still not appropriate for MRF rotating zone geometries. Here is a quick way for you to fix it in SimScale:

  • First, delete the enclosure and open the CAD mode:

  • In the CAD mode, select an external flow region creation and follow the steps below:

  1. Select the external flow region operation
  2. Define the enclosure coordinates
  3. Very important: exclude the rotating cylinder from the operation
  4. Hit Apply

At this point, you will have 3 volumes. The solid blades should be deleted from the geometry. Simply create a delete body operation and delete the blades:

Hit Apply and finally hit Finish. This will export the new geometry to SimScale, which will be appropriate to run MRF rotating zone geometries. As you can see, it contains the two necessary volumes.

Cheers

There is a warning when I want to generate the mesh it said that my simulation setup is not valid. I’ve created the flow region using the method suggested and defined the rotating zone as a cell zone. Do you have any suggestion on how to fix this?

https://www.simscale.com/workbench/?pid=2003932574751838362&mi=spec%3Ac864652f-5ecb-4bf5-bc1c-2b8622f9b2cd%2Cservice%3AMESHING%2Cstrategy%3A36&sh=22

Hi again, the issue will be resolved when you generate the model the correct way, as Ricardo mentioned. All the steps are described in detail, so I believe this thread is settled :slight_smile:

If you recreate the steps and there is still an issue, let us know, cheers!

A post was split to a new topic: Warning while selecting mesh with MRF region