Step-by-Step Tutorial: Homework of Session 3


#61

Yes of course I checked the spam folder. That’s why I even tried different emails as well to see if something went wrong the first time. But I simply don’t receive any email.


#62

@Milad_Mafi Hello there! I tried meshing adhering to the HW2 procedure, also taking account of changes regarding the geometry primitives placement. It was taking abnormally long amounts of time and the process was being killed, and also observed an abnormal amount of cells (almost more than 60 million). Your help regarding this would be most grateful.


#63

Thanks for checking. I looked at it again and I have no clue how to include it. The Base Mesh Box is not even showing on mine, even though I clicked “Show”, and I also increased the box to absurdly huge numbers just to see if something would come up, but all I see is the frontwing geometry. I also used Chrome and Firefox and its the same issue. Does anyone mind posting dimensions used for their mesh box? I’d hate for the submission deadline to pass because of something I couldn’t see.

https://www.simscale.com/workbench?publiclink=177be6ac-5ba9-4dcf-9790-55707385d12e


#64

Hi Milad,

I can’t import the modified geometry to Simscale. I got error 500. What does that means?

Thanks,


#65

I’m having an issue with my meshing - the log is pretty inaccurate :frowning: What to do?
Merging all faces of a cell

  • which are on the same patch
  • which make an angle < 180 degrees
    (cos:-1)
  • as long as the resulting face doesn’t become concave by more than 90 degrees
    (0=straight, 180=fully concave)
    [27]
    [27]
    [27] --> FOAM FATAL ERROR:
    [27] Multiple outside loops:0()
    [27]
    [27] From function combineFaces::getOutsideFace(const indirectPrimitivePatch&)
    [27] in file polyTopoChange/polyTopoChange/combineFaces.C at line 423.
    [27]
    FOAM parallel run aborting
    [27]
    [27] #0 Foam::error::printStack(Foam::Ostream&) at ??:?
    [27] #1 Foam::error::abort() at ??:?
    [27] #2 Foam::combineFaces::getOutsideFace(Foam::PrimitivePatch<Foam::face, Foam::IndirectList, Foam::Field<Foam::Vector > const&, Foam::Vector > const&) at ??:?
    [27] #3 Foam::combineFaces::validFace(double, Foam::PrimitivePatch<Foam::face, Foam::IndirectList, Foam::Field<Foam::Vector > const&, Foam::Vector > const&) at ??:?
    [27] #4 Foam::combineFaces::getMergeSets(double, double, Foam::HashSet<int, Foam::Hash > const&) const at ??:?
    [27] #5 Foam::meshRefinement::mergePatchFacesUndo(double, double, Foam::List const&, Foam::dictionary const&, Foam::List const&) at ??:?
    [27] #6 Foam::autoLayerDriver::mergePatchFacesUndo(Foam::layerParameters const&, Foam::dictionary const&) at ??:?
    [27] #7 Foam::autoLayerDriver::doLayers(Foam::dictionary const&, Foam::dictionary const&, Foam::layerParameters const&, bool, Foam::decompositionMethod&, Foam::fvMeshDistribute&) at ??:?
    [27] #8
    [27] at ??:?
    [27] #9 __libc_start_main in "
    [27] #10
    [27] at ??:?

MPI_ABORT was invoked on rank 27 in communicator MPI_COMM_WORLD
with errorcode 1.
NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.


mpirun has exited due to process rank 27 with PID 7244 on
node exiting improperly. There are two reasons this could occur:

  1. this process did not call “init” before exiting, but others in
    the job did. This can cause a job to hang indefinitely while it waits
    for all processes to call “init”. By rule, if one process calls “init”,
    then ALL processes must call “init” prior to termination.
  2. this process called “init”, but exited without calling “finalize”.
    By rule, all processes that call “init” MUST call “finalize” prior to
    exiting or it will be considered an “abnormal termination”
    This may have caused other processes in the application to be
    terminated by signals sent by mpirun (as reported here).

This is my project link:
https://www.simscale.com/workbench?publiclink=4f85eede-74d6-4168-b964-3687a671bbed


#66

So like someone else, I get the error message when running my simulation:

The job execution was aborted. A possible cause is that not enough memory was available. In this case, selecting a larger instance or using a coarser mesh should resolve the issue.

What am I to do? How did you fix it?


#67

And now it works…at least the mesh generation completed. Started all over in CAESES and created a new rear wing setup


#68

Nice to hear that! It would be great if you could share your results with us!

Since this homework assignements is quite compley we have decided to extended the submission deadline till 17.04.2016


#69

Hi Nadia,

Can you please check the size of your mesh and the number of CPUs you selected for your simulation? Mesh should be about 3 mio 3D elements and the simulation should run on 16 or more computing cores.

Cheers,

Milad


#70

Hi,

Since we are manipulating a paramateric model it is possible that pur mesh setup is not working out of the box for some specifice geometries. Unfortunately I can not import your link. Can you please check if the project is public.

@Ali_Arafat
Do you have any idea regarding the error message?

Cheers,

Milad


#71

Hi Carlos,

Are you sure that you selected the right file format when exporting your model?

Cheers,

Milad


#72

I have 132 CPU’s and 1.392.209 3D elements (volumes)


#73

Hi,

your baseMeshBox is much to big. You are using the wrong coordinates. Please try (-5 -5 0 15 0 5).

Cheers,

Milad


#74

Hi Milad,

I just tried it again to upload the file and now I succeeded. I think it was my internet connection.

Sorry,
Thanks


#75

Hi @Milad_Mafi I already tried those values, and if you look at Mesh 1 in my project, you’ll see the rear wing model is not in the base mesh box. The solution will be inaccurate if the geometry its flowing over is not represented in the domain


#76

Of course I mean 32 CPU’s


#77

Hello everyone,

I don’t really know how to start with this homework. Do we need to create our own design using the software caeses? I have seen that Milad sent a link to Unai but when I try to open it a message says: File does not exist.

thanks


#78

Hi everyone,

I have a problem when I was trying to do the mesh.

I have this error

The tesselated surface is not closed. There could be a problem with the
CAD geometry (such as self-intersections). Please inspect your geometry.
Trying to proceed anyway.

@Milad_Mafi

I have tried several geometries and I obtained the same error.

Can somebody help me?

Is there any solution or should I do a new wing?

This is my project.

https://www.simscale.com/workbench?publiclink=8ec3f116-6bb2-47eb-8d0f-537c98b83c74

Thanks in advance.

Carlos


#79

Hi,

You should download the software CAESES. Then, using the file of the rear wing which is given in this tutorial you can create your own wing and export it to Simscale.

Cheers,

Carlos


#80

What are the lift and the drag forces? Pressure force z and…