SimScale CAE Forum

Restore simulation settings to those from an earlier successful run?


#1

Is there any mechanism fro restoring the settings from an earlier successful run en-mass?

It was working (at least completing) and then I changed something that screwed it up; and I’ve tried stepping through to find what I changed and something is different, but I cannot find it.

If I could restore that successful earlier set, I could try again from a known working position.

Hopeful, Buk.


#2

Hi again @mhere and nice to see you being so engaged in our forum :wink:

What you can do in the future is to work with copies of your simulations in the tree on the left side in the workbench instead of creating runs in one single simulation project. That way you can make sure to classify your projects according to simulation type, different materials, variation of loads etc.

Tell me if that helped you!

Jousef


#3

Partly. Had I done that, it would allow me to back track to an earlier (working) simulation,

But it wouldn’t inform me what I had changed between the two, unless I (again) try and capture each change in the names I assign tot he simulation.

Basically, I got this whole host of computing power available to me – my machine, and yours, – and I’m reduced to trying to remember what I changed and writing things on scraps of paper.

It also means that I am reduced to making a single change for every run I try, for fear that if it start crashing, then I won’t know which change crashed it. Even trivial changes – like increasing the number of cores from 4 to 16, are enough to cause a simulation that completes, to start failing with one th your catch-all – something’s wrong errors.

My latest simulation, with just 2 parts and one motion, is just as fragile as my earlier more complicated attempts. And yet, so far, it hasn’t tested anything.

That is to say, the whole purpose is to see the effects on the TA, of the torque being transmitted from the axle; but so far, no force has been transmitted. The entire TA remains blue in the results regardless of whether you inspect displacements, or stress or strain.

That may be because I’ve reduced the penalty coefficient of the physical contact BC so low (as advised by the help for one of the other error messages in an earlier failure) that the TA is effectively made of plasticine; and just deforms out of the way locally without transmitting any force.

But if I raise the penalty coefficient above 1e6 (it should be nearer 1e16?), the simulation again fails with a catch-all error that the only apparent fix is to change the simulation such that it doesn’t reflect reality.


#4

Hi @mhere!

Things are starting to get a bit messy - are you referring to the project Guillermo (@ggiraldo) has already had a look at or another one? I would keep the technical/simulation issues in the other post and focus here just on the options you have inside the platform to sort things a bit more efficiently.

For changes I generally give the meshes or simulations meaningful names as if you are defining a variable in a program. Also making single changes like changing the core should not be put into another duplicated simulation but can be kept in the same simulation with a slightly different name (e.g. XY_16cores). Regarding the other questions for the penalty coefficient we will answer that in the other post you opened, hope that’s okay :slight_smile:

If you have any specific wishes or ideas on how we could improve the user experience feel free to share your ideas here in the comments or create a feature request if you like, we always appreciate good feedback!

Cheers!

Jousef


#5

Sorry Jousef, but I don’t know which bit of my reply above you are referring to?

My reply above was entirely a response to your post to which I was replying. I had not seen or responded to Guillermo’s post a that point.

Any reference to my projects was just me relating the problems I perceive in trying to manage changes; I wasn’t asking you to investigate or solve those technical problems.

Basically, the entire environment would be much enhanced by the abilities to:

  • Compare sets of setting to discover differences – but that’s already been discussed.

  • The ability to revert/undo changes without having to remember what they were and where they were made.

  • At the very least, a comment field attached to Runs that allows me to record what I (think I) did to the settings for this run, in an attempt to correct the errors in the last one.

The latter would be better than my getting up this morning and sorting through the half-dozen post -t notes I wrote last night, trying to work out which order I wrote them in and which change I noted might responsible for the failure of the last run I tried last night that finally made me give up and go to bed.


#6

Hi @mhere!

I was referring to this thread: FE Simulation - Status: Error. I was not sure if you have any other project that you are working on and if not then we should keep questions related to the setup to this thread, that’s what I meant. :wink:
For the last point you mentioned this is actually possible inside the platform if you go to the run and open the point Settings (see attached picture). There is no comment field but all the settings are saved there - the “downside” here is that we offer no comment section so far. Does that help you a bit or is that something you already know?

Cheers!

Jousef


#7

Not really.

Without a tool to allow me to compare the setting from two different runs – thus tell me what I changed between those two runs – the best I can do is try to annotate the changes I made in the name of each run:

junk66

Where that last (bottom) one roughly translates to:

Axle bolt boundary condition changed from Elastic support to Remote Displacement with Z-axis rotation unconstrained and External point set to (0,0,10).

The idea behind the change was … {the rest elided as you don’t want technical issues in this procedural thread :slight_smile: }

Basically, somewhere between ‘CW(40) Penalty Coef:1000to100000’ and ‘AxelBC: …’ I made a change or changes that caused the latter to fail with:

“The solution matrix is not factorizable. This might be caused by an unconstrained rigid body motion or by overconstrained degrees of freedom due to multiple linear relations at at least one node.”

But, as The former (and Run4 & Run 5) had completed and produced results – albeit non-usful results – I had made several changes to try and make the results useful.

Then I broke it, and couldn’t (still cannot) work out which change is responsible. In fact, even when I manually undo all the changes I can find, new runs fail.

One step forward, 3 steps back 97 steps around and around in circles and no forward progress.


#8

Got your problem @mhere :wink:

I will definitely note down the query and will forward it. If you like please put your feature request into the Vote For Features section which makes it easier for us to track stuff users would like to see on the platform. If you want to get help for the solution matrix then here you go (if you did not have a look at it already :wink: ): MatrixNotFactorable - Documentation

P.S.: What I would have done is to open an Excel Sheet and put in all my stuff there or create some kind of map I can work with which is of course nothing that is built-in but would be a hundred times better than a piece of paper.

Cheers!

Jousef


#9

Hi guys,

Alternatively, you could download the runs, (Assuming there are at least results for time step 0), and compare the files in the case setup using the free software called diffmerge. This allows for two files to be compared (one from each case) and highlights differences between the two. The longterm solution of having maybe a branch versioning system (like OnShape if you have ever used it) would be the best solution but the above method might get you a solution in the short term.

Hope this helps,
Darren

Edit: might only be applicable in CFD, sorry forgot you were using FEA


#10

Hi Darren!

Thanks a lot for mentioning diffmerge! I downloaded it for code comparison which I need for university, very nice tip! :slight_smile:

Cheers!

Jousef