SimScale CAE Forum

Inflate boundary layer induced illegal faces


#1

Hey,
i like to add a inflate boundary layer to my mesh.

I choose this faces to add the inflate boundary layer.

This are the options for the inflate boundary layer (i. b. l.)

  • Layers: 6
  • Expansion Ratio: 1.3
  • Min thickness 0.00001
  • Final layer thickness: 0.027

The i. b. layers looks good on flat surfaces, but less on crooked faces.
Here are two example pictures.


Furthermore the i. b. layer create three illegal faces.

Checking faces in error :
    non-orthogonality > 70  degrees                        : 0
    faces with face pyramid volume < 1e-13                 : 0
    faces with concavity > 80  degrees                     : 1
    faces with skewness > 4   (internal) or 20  (boundary) : 0
    faces with interpolation weights (0..1)  < 0.02        : 0
    faces with volume ratio of neighbour cells < 0.01      : 0
    faces with face twist < 0.01                           : 2
    faces on cells with determinant < 0.001                : 0
Finished meshing with 3 illegal faces (concave, zero area or negative cell pyramid volume)

I looked into the documentation advanced settings for Hex-Dominat parametric but i found nothing, to avoid the face concavity or the face twist. :frowning:

But im sure the are “adjusting skrews” to avoid the illegal faces and do a nice mesh without any illegal faces :slight_smile: .
Which option i have to change to get a nice mesh ?

Bets regards
Kai


#2

Hey @Kai_himself!

Well an easy thing to do if you’re in a hurry would be to just switch from the Hex dominant parametric to Hex dominant. For “Fine” or “Very Fine” fineness, there is notable change in the Arch, as you can see here . If you want to use the parametric though, I can revisit this.
Best regards,
Fillia


#3

hi @Kai_himself
fsite is right. you can change the meshing setting or used her mesh.
as you mention there are some illegal face.

so I investigate your geometry and there are few knife-edges are present so I think that knife-edge makes problems in your meshing.


so I try to remove that edge and trying to make a knife-edge free model so to do that I made a small change (small cut) in your model. :point_down:

download the model from my google drive
hope my model did not make any problem in meshing. :wink:

Best,
Rohit.


#4

@Kai_himself: Mind that you can run simulation with some illegal faces. It is often a trade-off, as mesh size without any illegal face can be huge. So for first quick and dirt simulation I suggest to use small, but not so perfect meshes.

Cheers,

Retsam


#5

Sorry @Retsam, but in this particular case I have to disagree with you.

Not because I think that having these 3 illegal faces here will make much difference in the results, but because Kai has put so much effort into this project (as we both have been seeing), and we can be pretty sure that Kai is not looking for ‘eye candy’ results.

If he wanted ‘eye candy’ results, he would have had them within an hour or so of finishing his geometry :wink:

My experience with obtaining ‘accurate’ results is that you MUST follow ‘best practices’, if for no reason other than being able to ‘rule out’ issues like these illegal faces as a reason that you are not getting expected results (which in this case, includes the question, why are my layers collapsing in some places)…

AND, even with ‘best practices’ adhered to, I would consider myself ‘lucky’ if the results were within 15-20% of any experimental data (if the experimental data would even be available, if it is not available then all the more reason to follow best practices)…

@Kai_himself, if you really want to discover where those collapsed layers disappeared to, have a look here


#6

@fsite,
yeah, this is a good idea. But 3M Cells is a bit too much at the “very fine” level. I will try the Hex-dominant mesh.

@ROHIT_SR,
thank you again for your help :), i will try your “updated” geometry :slight_smile:

@Retsam,
okey, i didn’t know that, its a good hint to try some setups, to find the right mesh.

@DaleKramer,
yes, its for my masterdegree :confused:, so it has to be accurate.
Your link is very intresting and informative.

I looked at the model again in paraview with a sliceview.
It looks like, that the layers only deflating at the outside faces.

To erase the three illegal faces, i increase the surface refinment to level 2 (from level 1), and now there are no illegal faces, in my model. Now i will check rohits geometry, and Dales values mentioned in his y+ topic.

I will get back, when i run a few simulations.

Best regards
Kai


#7

Sooo, i tried a few new options to creat a good inflatable layer, but i was not succesfull :disappointed_relieved:.

I ran a few simulations on the Mesh 5 569k. This is the first inflate layer mesh attempt.
At all simulations the time step decrease fast to very small timesteps, like 3e-11 till -105.
I think it depends on the Mesh, even though the mesh was created without any error.
The following three pictures shows the Mesh 5 569k.

Mesh 5 was created with the standart values at:

  • min volume: 1e-13
  • min tet quality: -1+30
  • min determinant: 0.001

So i decide to create a finer mesh. According to Dale’s post i change two values to:

  • min volume: 1e-16
  • min tet quality: -1+30 (it’s still the same)
  • min determinant: 1e-9

furthermore, i add a feature refinemnt and increase the surface refinemnt up to level 2.
This are the mesh Names:

  • Mesh 5 2.8M Feature and Surface
  • Mesh 5 2.5M Surface (without the Feature refinement)
  • Mesh 5 2.8M Feature (without the Surface refinement)
    (all meshes where created with the same options)

The mesh is finer now, but the inflatable layer still disapear at some places.
Here are three pictures of Mesh 5 2.8M Feature and Surface:

The Hex-dominant algortihm i tried to.
In Mesh 7 1.3M Fine and Mesh 8 6.6M Very Fine.
Mesh 7 1.3M Fine




Mesh 8 6.6M Very Fine

But at this algorithm i miss the option “Layer size” to use the absolute lenghts.
So the first (smallest) layerheight is

  • Mesh 7 0.00179 m
  • Mesh 8 0.00093 m
    and it should be 0.01786 m

Ok, at Mesh 7 its only a power of ten between the layersizes.

It must be possbile to use the hex-dominant parametric to create a inflatable boundary layer, or not ?

Last but not least i got no illegal cells in all meshes :blush::sweat_smile:

Best regards
Kai


#8

I think when you relax some meshing parameters to retain more BL cells, that the reporting of illegal faces sets new ‘looser’ standards for what is an illegal cell… (I could be wrong there but that is my memory)…

So, those same, previously reported illegal cells may still be there… and may no longer be reported as illegal :wink:

Have you looked at the numerous ParaView quality stats on the meshes :question:


#9

Of course, you are right, i forgot about it. :slight_smile:
No, did you mean the Mesh Quality filter ?


#10

Yes, that filter calculates many different quality metrics for any mesh…

Don’t ask me about the relevance of them though… :wink: I have only used them a little for relative comparing between two meshes so far, there must be some docs on what the magnitudes of the different values though…