Allocating memory error

Hi everyone, I am trying a static simulation on a monocoque fuselage and I keep getting this error: “An error appeared while allocating memory. If you are using the Multfront or LDLDT solver, please choose a larger machine by increasing the number of computing cores. For the MUMPS and PETSC solvers you should additionally reduce the number of parallel processes used for the computation to allow a higher RAM per CPU ratio.” I tried to reduce the number of parallel processes as well as to increase the number of processors from the Simulation control menu. Still, I find myself blocked in the same error. If you could think of anything, let me know!

Hello @dani02 , I hope you are doing well.

Main reason of this error message seems like the application of the boundary conditions. As my colleague @psalecha1 explained in this post: when you apply remote force or remote displacement boundary conditions to the whole part with deformable behaviour, this will significantly increase the memory requirement.

I would recommend appyling this boundary conditions to only faces/bodies of interests. In your case, it can be a little tricky though, because the faces are not split and geometry only consists of only one face and body. You can go back to you own CAD software and split those faces accordingly. A workaround in SimScale platform is to use Split command in the CAD mode to divide your geometry into smaller sub parts. I tested one quick rough case here, just for demonstration purposes, by splitting the middle section into several parts to apply the remote force, and the end section to apply remote displacement boundary condition. It worked just fine with 16 processors and 8 parallel processes.

Untitled video (3) (1)

Hope these are helpful,

It was really helpful, thanks for the advice!