SimScale CAE Forum

Wrx Aero Analysis Enclosure/Mesh Error

https://www.simscale.com/workbench/?pid=8508065116484346126&mi=operation%3A11%2Cgeometry%3A9&mt=GEOMETRY_OPERATION

Good day,

Working on a CFD of a non-compressible fluid over a wrx chassis model that I have created. Currently struggling with making an enclosure around it and getting the error

" The flow region could not be created due to the following problematic entities: [face1@solid7] Please consider cleanup operations in your CAD tool."

I have downloaded the model of the car as an STL file and imported it in, when I did it imported fine but now is having issues with the faces. In the CAD model, it is all one body and no open faces. A

Any help would be greatly appreciated.

Hi @Calebi ,

It’s an interesting model, however it doesn’t seem to be watertight (we have some sheet parts). As a result of the non watertightness, we have these small artifacts causing issue with the flow volume creation:

Unfortunately, with the current model, I don’t think that creating a flow region will work. If cleaning up the model further is not an option (removing these sheet parts/artifacts), then I would recommend using the hex-dominant parametric tool, which should allow you to generate a mesh with the current model.

This meshing tutorial might be insightful: Hex-Dominant Parametric Meshing of Front Wing | SimScale

Cheers

1 Like

I understand that the model has sheet parts that can not be meshed properly. In Fusion I have the model as a solid body and a single part, I don’t fully understand where the artifacts come from or why they are there if this model originated from a solid body with now sheets in the STEP file.

Any tips on how to fix the model?

Thanks

Back again with some progress on the simulation. If you look at the simulation you will notice that the Hex-Dominant Parametric Meshing did not work as suspected. If it was something I did in the setup compared to the example given that would be appreciated. If the model needs to be reworked I would just need pointers on how to do that in the CAD I am using (Fusion). In CAD it is one complete body and should not have any seems.

Any help would be great

Hi,

From looking at your project, the hex-dominant tool worked as I expected. Naturally, from looking at the mesh result, the settings have to be adjusted as the cells are currently way too coarse and the background mesh box is too small.

To use this mesh, you would have to click on “Use mesh as domain”.

I’d recommend that you go through the tutorial that I linked in my previous message and also this documentation page on the hex-dominant parametric tool.

PS: make sure to have a thorough look on the following:

  • Bounding box resolution
  • Background mesh box
  • Refinement levels & mesh refinements

These will help you to adjust the mesh a little better.

Cheers

Hi,

I would also advice you to export from Fusion a SAT file. Usually this file are better than STEP files.
You can also install the Plug-in avaialable on the Autodesk appstore

This will allow you to push your geometry to an existing project on SimScale without having to leave the application or do cumbersome format conversions when saving the models you want to use in your simulations.

Hope this helps.

2 Likes

Good evenng ive currently been working on the Hex-Dominant Parametric meshing on a new project file attached below. After 130min of waiting and still 0% completion of the mesh (Estimated time was 120-130). Any idea on what could be causing this?

Current Project
Thanks

Caleb

From a quick glance, it looks like the mesh is too fine with the current settings.