SimScale CAE Forum

Worm traces in simulation view


#1

I am working on improving the airflow of a part cooling fan duct for a 3d printer. I am now able to get fairly good results with the simulation. I have two minor issues, however.
First, when I add particle traces to the simulation run, they don’t seem to be retained in the system, so I need to re-add them every time I want to see the view. Is there a way to make this consistently sticky? I am fairly sure they have stayed under some circumstances, but definitely not consistently.
Second, after I first generate the run, it is essentially empty, but when I return to it later, there are cylindrical worm tracks that appear to be some version of the particle traces on one side of the simulation. I have no idea what they are representing, or how to hide them.

The Simulation that was taken from is:
https://www.simscale.com/workbench/?pid=2417894775922761643&rru=e2d7ac92-a7b9-40cd-b323-90bc10875144&ci=3452c8c1-55f7-478a-88b8-d731166c4345&ct=SOLUTION_FIELD&mt=SIMULATION_RESULT

I should note that the worms are now visible in the screenshot, but not in the simulation, so consistency is still a little off…


#2

Cool visualization I have to say @acwest, well except the small “glitch” :slight_smile:

I have forwarded this to our engineers who will have a look at this - have you tried post-processing your case in ParaView offline and see if this issue persists?

Best,

Jousef


#3

I’ve been wondering what post-processing does, actually…


#4

It looks like I have found another issue for them to look at. These two views are of exactly the same simulation run, viewed at two different times, with the same particle trace setup, I believe.


#5

I will have a look at it later on @acwest - quite later here! :slight_smile:

Cheers!

Jousef


#6

Hi @acwest

This is not an issue as when you are simulating any problem the system writes some data files, which is 20 in your case. This data file contains all the info about your the variables(velocity , pressure blah… blah…). As your system only ran for 20 iterations(which is very lowand writes for only 0th and 20th iteration), it will show a large difference in the value of these variables but suppose if you simulate it for 100 iterations(solution stabilizes), then you will get a much similar output for the 100th and 80th iteration.
I hope that makes some sense to you. Plz clarify if you have any issue in the above explanation.

Thanks
Ani


#7

Hi @acwest: I suggest you check your simulation setup, as you should not have that velocity range (5 - 20 km/s). SimScale is tolerant to such a huge range, but practical results can be only useful for decorating your walls.


#8

I was thinking that had to be a scale display issue, my inputs aren’t particularly extreme, I thought. I definitely am looking into it, though


#9

oops, Metres cubed per second instead of Litres per second. That would do it…


#10

:man_student::sweat_smile::+1:


#11

There is a problem, though. Now that I have fixed the units, I am getting some very unbelievable results.
The highest velocity in the system now is as the particles exit the side of the pressure outlet at the closest possible point. As far as I can tell, they shouldn’t be doing that…


#12

There could be a mismatch between inlet velocity and outlet ‘capacity to evacuate’ that flow. Things go awry already after few seconds in your cooling zone… Check your assumptions about the outlet. :man_student:


#13

Hi @acwest!

Regarding the problems mentioned by you (not taking into account the physical reliability at the moment):

  • The “glitch” itself, where there are unexpected traces. How can I reproduce that?
  • Do the streamlines change everytime you re-open the project or are they not even saved?

Best,

Jousef


#14

I haven’t had a chance to look over the numbers since I ran this, but the results seem wildly different than what I am getting with the actual physical part. Something isn’t right


#15

Found my issue this time, I needed to set the initial global pressure to atmospheric. Much better now…


#16

I haven’t found anything consistent about when it happens, or doesn’t happen, unfortunately