"The import of the model did not finish on time."

Description of the project: Doing external aerodynamics simulation of a Supra Mark 5 model. Compare the results between the absence and addition of a CAD-modelled rear wing.

What is going wrong: I’m trying to import the Supra CAD geometry. It is going through all the stages: importing, optimizing, etc., until I receive the error: “The import of the model did not finish on time. Please try to upload the model again and disable some import options (Improve data on import, Facet split and Automatic Sewing). Error Code: 22d78c64.”

What I have tried so far:

  • Importing as a STEP file from my computer.
  • Importing as an STL file from my computer.
  • Importing the STEP file from my computer onto Onshape, then importing from Onshape onto Simscale.

Link to the project: SimScale

My first guess is that the model is too complex, but I assume that would raise its own separate error if that were the case. I’m just a beginner, though, so I have no idea.

Any help would be greatly appreciated!


Hello Rhein, and thank you for using the Forum. There are a few other settings that you can try to resolve the issue without changing your model, such as disabling “Improve Data on Import” option while importing your geometry. You can try disabling other options as well.


However, I’d recommend you to perform some clean-up operations before importing your model for the best practicises in CAD import, and mesh generation. I see that your geometry contains lots of small faces, which will cause you issues during meshing even after successfully uploading the geometry. Please try to merge or remove these small faces in your geometry. Here are a few suggestions on complexity reduction of CAD models while importing.
Hope this helps.

Thank you for your reply! Yeah, I feared that the geometry would be too complicated. I will make a simpler one from scratch then try again!

Thanks again!