STL geometry from Netfabb is scaled up by the factor of 1000 after importing it to SimScale

Hi everyone,

I am trying to perform a compression analysis in SimScale, tho my geometry is scaled up by the factor of 1000 after importing it to SimScale. A length that was 40mm is now 40m as an example.

Here is a screenshot from my export settings in Netfabb, the size of the boundary box is displayed.

This is the size of the boundary box after importing:

I tried downscaling the geometry by the factor of 0.001 in CAD mode, this will produce geometry faults.

Here is a link to my project:

Is there a way to import the file maintaining the right dimensions?

Thank you in advance.

Hello @whense ,

Just a quick background information: stl geometries don’t have a “unit” attached to them, so the user needs to specify if the stl was exported in mm or meters or something else.

I can see that you are exporting from Netfabb in millimeters, however SimScale assumes meters by default. With that being said, there are a few options:

  1. Still in the import dialogue box from SimScale, you can change the units from meters to mm (i.e. as in this doc page)

  2. The second option is to scale the model down by 1000 in Netfabb and export in mm. This way you should be able to import in meters in SimScale and maintain the same scale

  3. The third option is to create the model in meters in Netfabb and export it in meters as well.



Hi whense & welcome,
I was interested in this feature mentioned by @RicardoParis but it took me a little time to work out where this specific feature was located, to change the scale on an STL when importing, even after reading the referenced Simscale doc, but maybe that’s just me :slight_smile:

Here is a screenshot of where I found the ‘Import List’ described and referred to by Ricardo. It becomes available when starting the import…Click on the green highlighted area to access the scale.

Another learning for me, thanks RicardoParis & whense:slight_smile:


Hi @RicardoParis,

Thanks for the background information about STL files, I didn’t know about that.

Also thank you and @ChuckMulder for the model unit option hint, this solved my problem.



Hi whense,
I read your question, brilliant. I see that a solution has already been provided & it’s down to you as it is so much quicker & easier to assist with possible solution/s when the issue is well laid out and explained, great posting to the forum :slight_smile: