SimScale CAE Forum

Step-by-Step Tutorial: Session 3


Howdy @l_trefiletti,

keep me up to date. :wink:



Hi @jousefm, @Milad_Mafi
I used your parameters in numerics of my simulation 1 (but they aren’t same of the tutorial!!). the simulation took 195 minutes (2000 sec simulation time), but I have an error on run (red bar!!!). However I have the results!!
If you can, take a look.



Hi @jousefm,

Thank you for your reply. I now have resolved my problem of simulation 1.
Can I use Hex-dominant automatic for internal flow (only CFD) for meshing of second simulation (with fan)? because I can’t find Automatic snappyHexMesh for internal flow as mentioned in the tutorial.
(snapshot attached)




Hi @l_trefiletti,

what exactly are the differences you have compared to the tutorial?

Sure there are always some fluctuations. You cannot expect a simulation to run as fast as others with the same settings :slight_smile:

And I see you are totally right! I missed to fix my numerical settings :slight_smile: But you can run two simulations and see what the differences are and if the settings I missed have a tremendous impact on the result!

Cheers and thanks for being so attentive!



Hi @radenpm9,

I am sure you can and should since we have a problem that involves internal flow(s). That’s also what I did and it worked fine.

Good luck and if you have any problems feel free to ask! :slight_smile:



@jousefm and @radenpm9 - Automatic snappyHex for internal flows was renamed to Hex-dominant automatic for internal flow (CFD). Thanks for pointing that out, I’ll update the tutorial to avoid confusion!

see: Farewell to snappyHex - it has been renamed Hex-dominant mesh



Hi @jousefm,
thanks for your reply. Then there is some difference between numerics in tutorial and yours. I uses yours (I think they are better anyway) and my simulation converged after about 200 minutes. In my first case I used the tutorial numerics and the convergence curve was very smooth, bur the convergence was too much slow.
One problem: the result of the first simulation is completed (I have the results) but there is an error (the bar is red!!)

cheers Luca


Hi @l_trefiletti,

you cannot say in general that mine is better (I would rather say that the options Milad choses are better because he has way more experience than I have). The approach to verify this “better or worse” issue would be a benchmark and see which simulation gives us the best results.

Concerning your error please try it with the simulation properties Milad has given in the description.

If you still cannot manage to finish your simulation contact me again.

P.S: Make sure you set up your boundaries in a proper manner!!!




Hi @jousefm,
unforunately I have the same problem.
I meshed again the component (passive) and set up the boundaries again for a new simulation, I think in proper manner, but the simulation is slow and didn’t arrive to the convergence ( the time exceeds), but the convergence plot is smooth!!
this is my link project :

could you check please?




Hi @l_trefiletti,

checked your profile and noticed that your boundary conditions in the section “Walls” are wrong! Check them again and make sure you do not assign two boundary conditions for the same entity. Try it again and let me know how it worked :wink:




Why only in the 2nd Simulation (with fan), in the Numerics it’s explicited the reference pressure value of 101325 ?


The 2nd simulation of mine also converged before the 2000th step. I had to lower the U and p residuals requested to reach t=2000. But since in this way the simulation at that final time is still not converged with the renewed and more strict residuals, I had also to change the write interval step not to risk to have no results written at t=2000.


Hi @gned,

Make sure your boundaries are set up correctly!

Good Luck,



hi @jousefm,
I think I was careful, but my first simulation is sleeping… and in your simulation the board plate is in WALLS BC!!!
WALLS is= all faces element - board - chip1 - chip2 - inlet - outlet, right or not??

I used topological entities to be clear…

cheers Luca


Hi @l_trefiletti,

neither inlet, outlet nor the chips1/2 are walls in my boundary “Walls”. With my settings I get the same results as Milad (at least in my passive cooling, did not adapt my settings in my active cooling - so treat with caution! ;))




@l_trefiletti - indeed you are correct on this

It appears the wall set still includes chip1 and chip2 (for simulation_passiv_bis)


thanks for your help
I fixed (finally) my problem…and simulations are over!!!

cheers Luca


and thanks @jousefm


Hi @l_trefiletti,

Was it the boundary setup?


hi @jousefm,
there was a double set up for chip1/2.