SimScale CAE Forum

Step-by-Step Tutorial: Homework of Session 3


#22

@Akrem @Milad_Mafi
Sir,
I finished meshing as per the step by step tutorial but I am getting stuck with an error in simulation at 21-23 mins after commencement of simulation process.
In the event log it shows that space required is insufficient and as per the help from the help section I tried it with 16 computing cores as well but still faced an error.
I need your help.
Link - https://www.simscale.com/workbench/?pid=734186859491352905#tab_1-0


#23

I also have the problem with the simulation. Ends after 20-30 minutes with an ERROR.

MESHER LOG

--------------------- Layer mesh : cells:12940712 faces:42134221 points:16498098 Cells per refinement level: 0 205190 1 8326 2 55638 3 44252 4 198319 5 1072242 6 2848651 7 3373015 8 5135079 Writing mesh to time constant Wrote mesh in = 38.12 s. Layers added in = 342.87 s. Checking final mesh ... Checking faces in error : non-orthogonality > 75 degrees : 57 faces with face pyramid volume < 1e-13 : 2 faces with concavity > 80 degrees : 0 faces with skewness > 4 (internal) or 20 (boundary) : 0 faces with interpolation weights (0..1) < 0.01 : 0 faces with volume ratio of neighbour cells < 0.0075 : 7 faces with face twist < 0.005 : 42 faces on cells with determinant < 0.005 : 33 Finished meshing with 141 illegal faces (concave, zero area or negative cell pyramid volume) Finished meshing in = 1200.38 s. End Finalising parallel run

SOLVER LOG

`–> FOAM Warning :
From function writeOldTimesOnSignalFunctionObject::sigHandler(int sig)
in file misc/writeOldTimesOnSignal/writeOldTimesOnSignal.C at line 162
This action may end in a segmentation fault
Set ‘writeCurrent false;’ to avoid this

mpirun noticed that process rank 2 with on node exited on signal 9 (Killed).
--------------------------------------------------------------------------`


#24

@s_giuliano @DeorajA @emin

Maybe it’s the maximun time run out of 3000s by default that’s causing this error, as this simulations should take over 5 hours the 3000s is reached before the simulation has ended, which might be causing this error.

Best wishes,
Luis


#25

Change the simulation control values according to homework 2 and create a new simulation run afterwards.


#26

Hi @emin,

that is caused by the simulation control imho. Increase the maximum runtime and restart your job. ~15.000s shoult be fine.

Let me know if that worked for you!

Cheers.


#27

I just started my meshing but after about 1 Minute it stops with an error.
I rechecked everything from the tutorial and have the exact same values everywhere.
My meshlog says:
“MPI_ABORT was invoked on rank 3 in communicator MPI_COMM_WORLD
with errorcode 1.
NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.”

Are there any solutions for this Error?


#28

Mesh operation Event Log.

Illegal triangles were found after surface tesselation. There could be a problem with the CAD geometry. Trying to proceed anyway.

The tesselated surface is not closed. There could be a problem with the CAD geometry (such as self-intersections). Please inspect your geometry. Trying to proceed anyway.

Mesh quality check failed. The mesh is not OK.

Should i try the simulation , or remake mesh ?


#29

@AlexanderKon,

proceed with the simulation setup.

Cheers!


#30

Hey guys!
I’ve got a question:
In the Simulation Setup, it says the following:

but, in Mesh Setup, we are told to create the zones to FrontWheelZone and RearWheelZone:

are they the same?
Thanks in advance!
Best regards,
Guilherme


#31

Hi @Akrem,

I’m getting cells inside the front wing, so there might be an issue with the geometry. Could you check?

Cheers.


#32

Yes, its the same.


#33

Hi @pfernandez,

I had no issues following Akrem’s step-by-step tutorial.

It seems like you modified the surface mesh refinements and this may caused a problem. Can you take a look?

Cheers,

Milad


#34

thank you Jousef,

I tried again with 15000s but the simulation got killed after 24min again.


#35

That’s weird, because I am also using the exact same values. Anyway, I fixed the issue by using the surface mesh from previous homework after applying symmetry.


#36

Hey guys!
My simulation finished without any worries, in 261 minutes.
The only problem I’ve got is that most results didn’t converge:


What can be wrong?
Project link
Thanks in advance!
Best regards,
Guilherme

EDIT: After post-processing following the tutorial for the homework 2, as indicated on the part 2 of the tutorial, my streamline is nothing like the example one.


What can be wrong? @Akrem @Milad_Mafi

Thanks in advance!
Best regards,

Guilherme


#37

Try setting the End time value in Simulation Control to 15000s


#38

Hi @jousefm
I tried running my simulation but it shows an error" The computation hours will be exceeded" and it does not allow me to start the simulation. I would highly appreciate if you could please help me with this.

Thanks & Regards,
Abhishek Soni


#39

@jousefm tried running the simulation at 15000s max runtime. the simulation showed an error at 22min run. please help


#40

Moved the conversation with @asoni and @subodh to private.


#41

@gmorandini

From the residuals your simulation converge really well! can you share the results of the forces?