SimScale CAE Forum

Simulation Error


#1

Hi,

I keep getting this error when I try to perform a Incompressible simulation.

“Mapping of assignments from geometry to mesh failed.”

I am not sure what this error means and how to rectify it. I even tried going back to previous projects that had successful simulations and attempted to run a new simulation and received the same error.

Any help would be great. Thanks!


#2

Here is the project: https://www.simscale.com/projects/parkerb/sad_asd_asd_asa_sa_a/


#3

Not sure, see no error there.

But I’m pretty sure you need to set an outlet boundary condition, likely 0Pa… before you can run it…


#4

Hi Dale,

I updated my boundary conditions. If you try to create a simulation run you will get the error.


#5

Likely if you keep chipping away at making sure the cited faces get assigned then it will work:


#6

Hi @parkerb!

Could you let us know if Dale’s tip helped you? If so then please mark his answer as the solution, thanks!

Jousef


#7

Hi @jousefm,

It hasn’t worked so far. Usually, when I don’t assign all faces a boundary condition it defaults them to a non slip condition. I have never had this particular error before and I haven’t found a solution yet.


#8

Does that mean that you did assign all faces, you no longer received the above assignment error and still it did NOT finish a sim run ?


#9

I assigned all of the faces that I wanted to assign and the others defaulted to a non slip condition which is what I wanted. Still having an error.

In the past, I only assigned the faces that I wanted and Simscale applied a non slip condition to the rest. This was working in the past. The “mapping of assignments from geometry to mesh failed” error is new.


#10

IMHO, things that work in the past UI or WB don’t always still work in the new, and also that even when a dialog says that something happens it may not happen…
My suggestion was just to try to rule out potential issues in all ways from a thorough perspective…
Hope you find the issue and report back here…


#11

Thanks Dale,

I will clean up my model and try again and let you know.


#12

Hey,
Even I’m getting the same error when I try running my simulation.
“Mapping of assignments from geometry to mesh failed.”
Did you manage to find a work around for this issue?

Best,
Scram


#13

Hi @sriramchari1 and @parkerb

Have you guys tried working with step format?? May be this error is due to the igs format. One user was having some difficulty in making mesh in which he was working with igs CAD file. If your problem gets solved by changing your CAD file format from igs to STEP then Simscale engineers can check if there is any issue in how the igs format files are being treated by the solver.

Thanks
Ani


#14

Thanks for your file Ani!! I’ve not tried it yet. But as far as your last question is concerned, I was using a STEP file all along. So, that issue persists for STEP files as well. I’ll try running the cleaned up CAD model that you uploaded and revert if its working or not.
Thanks for your time!

Best,
Scram


#15

The new CAD that you uploaded works Ani! I have a question though. Any idea how to find the torque at the rotating component? I used the forces and moments option and selected all the faces inside ‘zone’ but it gives me zero throughout.


#16

Well, I see nothing rotation in your project, but if you have one with blades, set one blade for measure forces and moments. If you select all, vectors cancels each other with different signs. With that data from one blade you can calculate your torque on rotation body.


#17

Thanks for your reply Retsam!
The reason why blades are not there is because the geometry was created using a boolean expression to remove the blades and a negative space in its place. A rotation zone was created around this cavity to mimic rotation of the blades (MRF was used in this case). This was done because I couldn’t mesh the domain properly with the original CAD with the blades. (Check my first post in this thread). Now, I’m able to mesh it and run the simulation but am not able to select the blades as face while setting up the torque computation. Do you have any work around to this?

Thanks!
Scram


#18

Sorry, calculating forces on void would not work. CFD is done around material objects…