Simulation Error - Velocity divergence

There is velocity divergence problem for my simulations. It is weird that I created the probe points and the error occurs actually inside my building block (solid block) as demonstrated in the picture so it is nothing to do with my mesh settings. Also, it is far away from any boundary layers.
This is my project link, the problem occurs for the last several simulations. SimScale

Also, I have testified different grid refienement and it is still the same. The erros occur at different locations every simulation. It’s so weird. Hope I can get someone answered my question. Thank you!

Hi, thanks for using the forum.

You need to improve your mesh quality, as I can see that your max non-orthogonality and aspect ratios are above the recommended values:


Please refer to these articles for instructions on how to do so:

Hi thanks, but why divergence occurs at the point inside a block. There’s no mesh at all.

Dear @shushen0329 , I tried to enter but there is no mesh. Is that the actual link?

Hi shuishen0329

it seems like the points are also very close to the walls, You can see that better in a top view.
For example this point is 0.5m away from the wall. in comparison with the whole size of the domain and the x position 311m this is of by 0.1% of the wall.

I think this has something to do with the accuracy that these values are calculated and presented.
So as ggiraldof suggested please inspect the regions close to that wall and improve the mesh quality.

Best regards