SimScale CAE Forum

Running out of memory

Hi everyone,
I’ve imported a honeycomb IA cad model to conduct crash Analysis. Also in order to avoid the complexity in the analysis, I just imported 1/4th of the model by using the symmetry relation. By taking into account of all the constraints, the analysis is no near the completion and has gotten stuck at 12% for very long time and almost 122 minutes have passed. So could u guys help me out here,
https://www.simscale.com/workbench/?pid=5534743699986015134&mi=run%3A38%2Csimulation%3A2&mt=SIMULATION_RUN

Hi,

The physics of the impact are quite complex with this model, so the timestep size around the impact will naturally be very low.

I noticed there is currently only one symmetry condition in the setup. Are you running half of the model, or a quarter of the model? It would be best to run a quarter of the model only.

Finally the timesteps look a little large. From a hand calculation, the impact should occur at around 0.006 seconds (16.67 m/s and around 0.1 meters of gap). In the current settings, we are starting off with 0.005 seconds of step size, so this could be lowered a little further (see a rule of thumb here).

Cheers

Thanks for the suggestion but even with the 1/4th of the model I was not able complete the analysis so I took the 1/16th part of the model with the time-steps u mentioned. Though I was able to complete the analysis, the model is penetrating through the wall. I think I’ve assigned the constraints properly but could u guys once check and help me out here…
https://www.simscale.com/workbench/?pid=5534743699986015134&mi=spec%3Ad1f1356d-e035-47be-95b8-c8559a0a9bb2%2Cservice%3ASIMULATION%2Cstrategy%3A2&ps=analysis%2FsimulationControl

Hello, make sure to go through this documentation page, which talks about this topic: Physical Contacts in Structural Simulation | SimScale

Cheers

I tried the simulation by using the penalty method by multiplying factor upto 100 of youngs modulus and also tried with the Lagrange method as the nodes were below 100000, but there is some error with the timestepping led to a timestep below the minimum threshold. I followed the steps they which u can see with my different simulation run. Can someone help me out here.

Hello,

The documentation contains several articles about common errors.

For instance, the one you are facing is due to the newton convergence not being achieved, which results in the timestep size getting divided multiple times until it falls below the minimum threshold. At this point the simulation fails.

Make sure to check this documentation page for insights: Error: Newton Convergence Could Not Be Reached | SimScale

Tagging the @fea_squad here, in case anyone wants to chime in.

Cheers

As I’m conducting the crash analysis with 16.67m/s with 100mm gap, the time interval comes around 0.006s, So I went with the timesteps as

  • Up to 0.01 s, the time step is 0.003 s,
  • Up to 0.03 s, the time step is 0.0015 s,
  • Up to 0.05 s, the time step is 0.0007s.
    But still there was an error with the Automatic timestepping led to a timestep below the minimum threshold. I followed this approach and made required changes but still there was the same problem. So can u guys resolve this issue

So inorder to avoid all this confusion, I went with standard conditions of crash analysis at 7m/s with 67.5mm gap, the time interval comes around 0.0096s, So I went with the timesteps as

  • Up to 0.01 s, the time step is 0.005 s,
  • Up to 0.03 s, the time step is 0.002 s,
  • Up to 0.05 s, the time step is 0.0001s.
    But still I’m facing the same issue, so can u guys help me out here.

HI @sr_rao,

I had a quick look at your project. The only area that I am not sure about is in the physical contact definition. Usually, the Master surface has the least amount of “stuff” going on. Meaning less curvature, less stress, less deflection, and stiffer.

For a quick experiment I made the concrete surface the master, made the closest steel plate the slave and ran the model. It finished in 57 minutes. I am thinking by having so many master surfaces defined it is causing convergence issues resulting in too small of a time step. Using this as a starting point you can start to add the other surfaces in as slave surfaces to the concrete master until you have defined the contacts the way you need.

Check out Run 21.
https://www.simscale.com/workbench/?pid=8209113948743183929&mi=run%3A78%2Csimulation%3A2&mt=SIMULATION_RUN

I hope this helps out.
Christopher

1 Like

Thank you very much for helping out, but I had one query as u can see I’ve used the scale down model viz., 1/16th part of the original model. So can we consider the results of original model similar to the 1/16th of model, or do we need to multiply by some factor and then interpret the results??

Hi @sr_rao,

It would be best if you had some experimental data to compare with to make this decision. Without any experimental data I would want to simulate at least 1/4 of the model.

You could also compare your current model (1/16 with the step in it) with a section of the model without the step in it and compare the difference.

Good Luck,
Christopher

Okkk thanks :+1: