SimScale CAE Forum

Refinement box can't be pick for region refinement + background mesh box not part of the mesh


#1

Hey guys,

I set up a very simple model (a cube and a cylinder) to test wind simuation.
https://www.simscale.com/projects/sholz/windtest/

Maybe you could helb me with two problems:

  1. Within simscale I created a refinement box for a region refinement but I can not pick it. Instead I can only pick the imported geometry.

  2. When I generate a mesh only the imported geometry is meshed, not the background mesh box.

Thank you very much for your help.


#2

Hi @sholz!

Pictures or Gifs on these kind of issues is always helpful! However from what I can see you already created a mesh so choosing a new refinement would not be possible right now. What you do is open the mesh tree and then select the dropdown menu of existing meshes and duplicate the one you already created. You should then be able to assign your region to the refinements you defined.

Also make sure that the material point is not inside your geometry and that your geometries are always watertight to avoid any problems during meshing.

Let me know if that makes sense - happy to help if there’s anything that was not clear enough from my side!

Best,

Jousef


#3

Hi jousefm,

Thank you very much for your reply.

I duplicated the mesh and tried to assign the refinement box as volume for region refinement, but still I cannot pick it. Attached I send you a screenshot.

I also double checked and the material point is outside the geometries but inside the background mesh box (wind channel), that’s correct, isn’t it?

For my other question: When I generated the mesh, it appears as shown in the second screenshot. Normally, the background mesh box (wind channel) should be meshed as well, shouldn’t it?

Thank you very much for your help.

37|690x430


#4

Hello @sholz,

Screenshot you attached shows correct behaviour: your mesh "geometry primitives’ does contain ‘refinement box’ definition. In ‘Region refinement 1’ frame, you just switch the ‘slider’ on: it is currently on, so region IS defined. You do not need to pick volumes. Kind of exception for mesh definitions…

Cheers,

Retsam

P. S. You need ‘external’ mesh, not ‘internal’ for your CFD simulation. It should answer you second question…


#5

Hello Retsam,

Thank you very much for your kind reply, it works now!

Cheers,
sholz


#6

Very good and important hint on the “external” vs. “internal” issue Andrzej, good job!

@sholz, please mark the answer of @Retsam as the solution, thanks!

Cheers!

Jousef