Post-Processor - no loading


#1

Hi, i’m doing 1st tutorial - solid mechanics. I did everything exactly same. When i’m in post processing i can’t load my work. Loading bar is running and no effect. I waited very long, tried on chrome and on mozilla. Still no effect.
Any ideas ?


Problems with Post-Processor
#2

Hi acros787. Since it is just a tutorial, could you please share a public link, so we can have a look at what may have gone wrong?


#3

Link from my browser will work, or some special type of linking ?
https://platform.simscale.com/?_ga=1.175037858.1654904303.1440495980#tab_3-0


#4

You need to create a public link. To be able to do that, you should:

  • Go to the Workspace Tab
  • Select the project you want to share
  • Click the blue share button close to the top
  • Click generate public link
  • Paste the generated link here.

You should do this (public links) only for projects that are not confidential, and since this is a tutorial, a public link will work just fine. Otherwise, you would normally share it with support.


#5

https://platform.simscale.com/?publiclink=22a3987c-db5f-4c65-b9c4-19d2bbe2af5a


#6

Thanks for the link. I have imported the project and I can visualize the results in the post-processor. There are several reasons for which the post-processor might fail. These are some of its requirements:

If both of these requirements are fulfilled, then we can proceed with looking at what the javascript console is returning as errors.


#7

Shows me that my browser supports both - WebGL and Websocket :confused:


#8

It’s ok, let’s then try to see what error message is being printed to the browser console.
To open the console, do the following:
Chrome: Press Control+Shift+J or go to the menu next to the address bar -> More Tools -> JavaScript Console.
FireFox: Press Control+Shift+J or go to the menu next to the address bar -> Developer -> Browser Console.

Once the console is open, open the project, go to the post-processor tab and click on the results in the Navigation panel to the left. Please post the last 20-30 lines of the console.


#9

By the way, could you also specify your Operating System and Browser version?


#10

When i try to use "reload post processor " button i get such error in console :

Try to connect using the direct WS url
autobahn.js:2398
Uncaught SyntaxError: Failed to construct ‘WebSocket’: The URL ‘wss://platform.simscale.com:ws://platform.simscale.com:/ws’ is invalid.
ab._construct @ autobahn.js:2398
ab.Session @ autobahn.js:2440
ab._connect @ autobahn.js:2977
ab.connect @ autobahn.js:3121
connect @ vtkweb-all.js:534
module.connect @ vtkweb-all.js:608
(anonymous function) @ vtkweb-all.js:4431
arg.error @ vtkweb-all.js:335
v.Callbacks.l @ jquery-1.8.3.min.js:2
v.Callbacks.c.fireWith @ jquery-1.8.3.min.js:2
T @ jquery-1.8.3.min.js:2
v.support.ajax.v.ajaxTransport.send.r @ jquery-1.8.3.min.js:2

When i do what you say, nothing happens in console. Loading bar is just loading.

My operating system - Windows 7 Professional with service pack 1
My browser is chrome - 44.0.2403.157 m and it’s says it’s actual.


#11

That is exactly the console debug output we needed. It looks like there is a problem creating the Websocket connection with to the post-processing server. I will try to reproduce the issue and write back a bit later.


#12

Reproducing the error and tracing the cause is proving a little bit more tricky than expected.I will write back as soon as I have more information.

A couple more questions to assist the search:

  • Are you perhaps behind a proxy or a firewall that might be more restrictive (such as a company/corporate network)?
  • Could you please confirm to me whether this happens also with FireFox or some other browsers?

#13

Yes it happens in firefox, safari and opera too :smile:
I tried also using other internet connection - still nothing. It works on my old PC :joy:, but i still need it ony my laptop.

When you said about firewall i got an idea.
And i solved it - avast. I turned off him for 10 minutes and it works.

Thank you very much for you time and help, you have great staff :blush:


#14

Great to hear you got it working :slight_smile:
Also good to know that firewall/antivirus software can actually affect the functioning of some components for a part of our users.

Have fun using SimScale!


#15

I ran into the same problem today working on my first tutorial.

The post processor did not start. Instead there was a pop up window saying:

Post-processing service notification
Connection to post-processing server interrupted. Please try again in a few moments.
:sweat:

I’m behind a company firewall and chrome-js debugger outputs the following:

WebSocket connection to ‘wss://www.simscale.com/ws/383c5fa2-0876-11e6-a34c-10bf48d757f9ae292x9073b09ady15212’ failed: Error during WebSocket handshake: Unexpected response code: 307
embed.html?runNameForResult=Run 1&projid=5283940566312168057&uid=1570061236&resultUuid=2fe378fb-fe7…:2468 Connection could not be established.

https://www.simscale.com/workbench?publiclink=50973179-9ea9-4f4b-a3b9-9658f560c344

I will try to call the post processor later today on my home PC to verify, if the firewall is the cause for this behavior.
:computer:

PS:
@ simscale team: Thank you for the excellent tutorials and webcasts.


#16

I checked at my home PC and the post processor started without a problem.
So i think that the company firewall / virusscanner is responsible for that behavior.


#17

@lger, thanks for reporting this to us. Glad to hear that you are enjoying the tutorials and webinars :smile:


#18

I’m faced with same problem.
I’ve run a simulation last night, and cannot open it’s result in post-processor – I see the wheel circling with no result. Same on my home and work laptops, chrome and firefox tried.
Moreover for all my other projects postprocessor is displaying same, but it worked just fine before yesterday.

The project that started it https://www.simscale.com/workbench/?pid=7349713893606642792#tab_2-0
simulation is called “unioned static”


#19

Hi @gkotelnytskyy & @Pavol_Kianicka !

Contacted one of my colleagues who will have a deeper look into this! Keeping you up-to-date!

(Related post for @Pavol_Kianicka: Why can I not view results in post processor even after successful simulation? )

Best,

Jousef


#20

Update: The issue should be fixed now! Apologies for the lost productivity!


All the best and happy SimScaling!

Jousef