SimScale CAE Forum

Permanent script warnings after upload of STP geometry, browser frozen often


#1

Hi SimScale team,

yesterday I uploaded a new stp file with a prepared car model (detailed with chassis, radiator and rough engine room components). I think the modell size and detail is nearly the same like in the F1 projects from Perrinn.
The stp size was a little bit more than 100 MB but it reflects a car model what is normaly used for automotive aerodymanics analyses.
The upload process did not end correctly independently if I tried to upload it as stp or as zip file. But after a click on the (x) of the upload field, the visit of the dashboard and after that a reopen of the project the stp file was shown in the model tree.
Now after choosing my new stp modell in the tree the browser window (mozzilla) begins to show script warnings and was frozen after click on a buttons or when I tried to turn the geometry in the geometry window. Sometimes it was possible to do a little bit but in general it is nearly impossible to work with the program.
Attached some screenshots of the CAD model and the script messages (German):





The project is not public for the reason that the geometry is from a real project.
Can anybody help? Has anyone an idea why the browser becomes frozen or why I get the script warnings.

… Short update from 23:07 pm.
I have seen that I did use the 32 bit mozzilla browser. Now I have updated to the 64bit version. The change is that I do not receive the script warning message again and the browser can now use more RAM. But freeze of the browser when changing anything at the model or project tree remains.


Error The material point is not inside the Bounding box
#2

Hi @jjanczyk, thanks for reporting this - we are taking a look and will get back to you shortly.

Best,
Anna


#3

Hey @jjanczyk!

Can you try chrome also just for a check here? That will be great! :slight_smile:

Best,
Ahmed


#4

Hello @jjanczyk,

thanks for reporting your issue and the detailed description! Could you share this project with our support. It would make it a lot easier for us identify the problem. If you share it directly via the “Share with support” button, it will be shared as a private project and we will of course keep your project confidential.

Best Alex


#5

Hi Ahmed,

I tried chrom browser (64bit) yesterday and also today again. It runs a little bit better than mozilla but the general problem remains. Attached some screenshots:

Now I have shared the project with SimScale support for better investigation as written from @afischer in post above.


#6

Hi @jjanczyk,

thanks for sharing the project with our support. I can exactly reproduce what you described. The model is quite large and complex with over 20k faces. I think the PERRINN is only half the size of yours. But as long as you can simulate it, we also want to make it work in our viewer. I created an issue for our development team and I will update the topic here. I do not have an estimation on how fast we can deliver an improvement yet, though.

Best Alex


Difficult meshing of geometry. Issue: Mesh at in and outside of the body (car) in despite of watertight geometry
#7

Hi Alex,

thanks for your investigation and your feedback.

Best Jens