Difficult meshing of geometry. Issue: Mesh at in and outside of the body (car) in despite of watertight geometry


#1

Dear SimScale Team,

since some days I try to mesh a vehicle geometry for a aerodynamics simulation based on data of a project from our past.
First I tried to mesh the full geometry inclusive rough engine room components and a radiator dummy to take the flows through the geometry into account. See link below:


Unfortunately it was not possible to mesh the geometry. In meshing tree there was signed that operation was ready for calculation. After I started the operation it looks like that process was running. For that reason I changed to dashboard and saw that just started meshing operation was ended with error. After I saw that I changed to the project and saw the status: “operation not ready”. I tried to start the meshing some times again. Every time with same result.
Than I changed the geometry to a less komplex CAD model without engine componets, open engine room and radiator channel. Unfortunately I did get the same result. But at my last try (I changed nothing) the process started correctly end ended up with a mesh. But at the mesh there was another issue: The geometry was meshed in and outside (Cad file was signed as watertight).
With these result I checked if there was a dimension problem in x-z plane. But it was nothing to find.
To avoid a problem in x-z plane (y=0) I extruted my CAD model a little bit in positive y direction for the reason I only use a half of the geometry. With that I was sure that x-z plane (symmetry plane of the _BaseMeshBox) cuts the model.
With these geometry I tried meshing again and again and again. But I got same errors as described above till I got a process which started succesful.
The end result of the succesfull meshing operation was a mesh which was in and ouside again. I can´t self explain why that happend for the reason I did work with a water tight geometry.
Attached the screenshots of the watertight geometry plus the mesh:

Can anybody help?

Thanks a lot.

J. Janczyk


#2

Hi @jjanczyk given that your project is private it is hard to see what went wrong. Are those finer meshes regions you purposely defined? Is your material point clearly outside (or inside) as it is supposed to? To be completely honest, I believe that the error is your geometry. You have the right approach by starting simple. “watertight” geometries can still fail when they are encrypted into step/iges and loaded to a different software as surfaces. What I recommend you is that you turn the surfaces into solids without voids inside, if that doesnt work, then do a Boolean operation (create the tunnel in your CAD software and substract the volume of the car in your CAD software) and load the “tunnel” so that there’s no inside to be read to begin with.


#3

Hi @oscarcorripio,

thanks for your reply.
I checked the stp file different times with two different CAD tools (CATIA V5 and Geomagic Design X). I converted the file from .CatPart to .stp and read it back into the tools. Result in both tools was a 1 piece solid as it also written in the simscale geometry import check box. Below screenshots of both systems:



The material point is placed correct and far away from the geometry. It lies inside the BaseMeshBox. The refinement areas you see in the screenshots I did manual for the reason to get finer mesh in these regions, but in first step it is only necessary for the outside mesh.
Before I tried to mesh the current geometry I did run the same simulation with a much coarse dummy geometry without any problems.
The way you mentioned with the tunnel and subtracted solid is the way I will try as next. Maybe to work with a .stl file can be another step.
But in general the mesh result remains unclear for me.


#4

Below screenshots of the mesh I did generate with dummy geometry:


#5

The fact that you were able to mesh properly with dummy geometry confirms that your procedure is correct and the issue lays in the geometry. Would you consider sharing the geometry? If not, how about the subtraction approach that I suggested? Its not the same process but it should be able to provide similar results. Another thing I suggest you is to try to simplify the geometry a little more. I know you mentioned removing parts but maybe even certain features might not that significant towards the effects of the geometry (or you could evaluate them separately) this will make the meshing and computations more simple and less likely to fail but also it might address the geometric features that produce issues.


#6

Hi @oscarcorripio,

thank you very much for your tips. I have generated the volume of the basemeshbox wihout the car body but did not load it up to my simscale account for the reason I tested a little bit with stl - files which is much better with this complexity than to use step - data. Simscale runs normaly, no frozen browser etc. For the first it is good. Now I have the challenge to cut the stl for surface refinement zones and turning walls.
Additionaly I must change to free subscription for the reason my CPU hours are empty. But with stl - file it is no problem to share it in public zone for the reason there are no generic data.
Now I must wait to try to generate a mesh with the new geometry. :slight_smile:

Thanks and a nice weekend I wish for you

Jens