Model not behaving as solid body, Rear wing being divided into end plates and wing

I am trying to run a CFD analysis on a rear wing I have designed for a university assignment, however, when i import the model into simscale, the solid body behaves as two seperate entities and the simulation fails. it also does not allow me to create an enclosure around my model, however when my lecturer tries it, it works fine, is there something wrong with my simscale?

Hi, thanks for using the forum!

I made a copy of your project and was able to create the flow region with no issues, have a look:

Perhaps there is an issue with your workflow. Please follow the instructions given in this page:

Now when I set up the simulation, when i go to generate the mesh it says simulation not valid. i have followed the tutorial provided exactly. i assume it has something to do with my model but i cannot figure it out

Can you please share the exact error message that you received?

This is the error message I am receiving. I clicked generate mesh anyway but I do not think the mesh was correct.

Hi there CameronD21,

Welcome to Simscale, I see you had a missing wing in the original question posed & expected you may have solved the issue. As I’ve indicated in red, there is a toggle ‘eye’ button which needs to be clicked ‘on’ to allow the wing feature to be seen. Don’t worry, this was a common trap for me in the early days, just keep an eye on what is turned off/on at the right hand side of the screen.

Ok, the next thing…I don’t think you have deleted your body from the simulation flow volume.
I know it sounds counterintuitive, but this is required to create the correct environment.
I looked at the Simscale CAD model and it needs to be transformed so that a simulation can be performed, but the model hasn’t been deleted. You are halfway there…go back to the Simscale CAD environment and delete the Airfoil using BODY delete, as highlighted and then choose ‘Export’.

This tutorial might be helpful, just ignore the initial import or the Simscale model and use your own but, don’t forget to delete the the model in the Simscale CAD setup

This image from the tutorial shows the steps in the deletion of the model from the External Flow Volume. Make sure you use the menu item within ‘Bodies’, don’t use the ‘Faces’

If you stuck again, let us know :slight_smile: , we have all been down this road, good luck with the uni assignment.

Hi Ted,
thank you for taking the time to help me with this, thanks for your advice about deleting the body from the flow region, I did not know this. However when I am creating the topological entity sets, how do I select the whole spoiler like in the tutorial, it only allows me to select the individual faces of the body, i think this is the mistake i am making. Many thanks.

Hi CameronD21,
Thanks for the feedback and your question about…
“how do I select the whole spoiler like in the tutorial, it only allows me to select the individual faces of the body”
Ok, when you are in the Workbench screen of Simscale (ie main screen of the project).

  1. This is my practice, Go to the top of the screen click on…this “select faces” icon.
  2. Then hide the external flow volume by click & turn off the ‘eye’ icon, so you can see your model.
  3. Click on the dotted square outline, to activate the ‘box selection’
  4. Move your curser to an upper corner of the spoiler, hold down left mouse button & drag a square around the spoiler
  5. Click on the ’ + ’ symbol above the topological to enable create and label feature.
  6. Enter in your name for the new topological set say " spoiler" and click the ‘Create new set’
  7. You should then see a new topological entity called ‘Spoiler’ , & then you may have to click on the adjacent ‘eye’ to see it.

Hopefully the above steps helps, the screenshots are of a disk of mine in an external flow volume, but think of this as your spoiler model. There are a few ways of selecting objects, I’ve just mentioned one way that works for me. Don’t worry, it took me some time to get the idea. Just be careful that you only select your spoiler model and not any other faces of the external flow volume.

Again, have any problems, get back to me, sorry for the delay in responding.

1 Like