Meshing refinment did not work


I try to refine the meshing within a cylinder, as shown on the pictures, but the refinement does not work.
Is there an obvious reason to that or a methodology issue ?

Thank you for your help!


I’m not sure if I understood exactly what the issue is. The refinement is currently set to a maximum edge length of 5e-5 meters and, since the outlet section is much smaller than that, you are getting cells that are smaller than the refinement (i.e. in order to capture the outlet).

In short, this looks expected to me, since you are only defining the maximum edge length with the refinement, not the minimum edge length. There would be no way to capture the outlet if a 5e-5 meter cell was enforced.


Hi Ricardo,

Thank you, yes you are right. But I tried with smaller size :

And I still did not get the same mesh result.

I believe it is a similar, simple, issue as you said but I can’t find it… Maybe something related to the volume assignment ? Or something else?


Having a look at the meshing log, we get an explanation for your latest test. I’m highlighting the lines of interest:

For the Parasolid kernel (which is used in the platform), the maximum precision that a model can have is 1e-8 meters. This particular model that you have was exported with a precision of around 4e-6 meters.

However, from a meshing perspective, the precision is going to be about an order of magnitude greater than the CAD precision. Otherwise, if you push the mesh precision too close to the CAD precision, you may end up with nodes being placed in wrong locations.

In the aftermath, since your region refinement is smaller than the CAD precision, you will end up with a coarser mesh than you anticipated.



Ok thank you! I will try to refine the CAD file.

Have a nice day

1 Like

Hi again,

How do I refine the CAD precision? Is it possible to do it in SIMScale?
I tried with the meshing settings but did not work :

And I am using step file so I don’t think there is a resolution attach to this kind of format?

Can you direct me on this?

Have a nice day

Hello, this is often related to the CAD software that you are using (export settings/format/precision). On the SimScale side of things, the only thing that comes to mind is to play with the import options (e.g. turning “Improve data on import” on/off and seeing what the meshing log shows for maximum precision).

Outside of that, the workflows would involve your CAD software. The “Small feature suppression” setting that you mentioned is not related to CAD precision.