SimScale CAE Forum

Mesh fineness is too close to the model tolerance

Hi everyone,

I am trying to generate a mesh on this project: https://www.simscale.com/projects/miltos980/clc_flow/

This message appears and I can’t work it around so far.
image

I can understand that there is a problem with this highlighted edge.

But I have used the exact same geometry with no problems in this project: https://www.simscale.com/projects/miltos980/extyernal_flow_cht/

Could anyone suggest a solution?

Hi Miltos!

Personally I would suggest you switch to the Standard mesher. We have a variety of external aerodynamics tutorials using this meshing algorithm that you could use as reference( like this one for example).

Another suggestion would be to simply fix those two surfaces in your CAD software tool and re-import the model. It is better to eliminate the source than trying to resolve the issue with additional settings.

Let me know what you think :slight_smile: Which CAD software are you using by the way?

Best regards,
Fillia

Hi Fillia,

Thanks for your reply.

The Standard mesher is the one that I am using.

I also think that the best solution is the correction of the geometry.
However I have a hard time trying it, becasue when I am changing something on the geometry, other errors ocour, so this is a time consuming trial and error aproach.

The CAD software that I am using is Inventor.

Best regards,
Miltos

1 Like

Is it possible that you export the model in STEP format, and try to re-mesh?

Thanks for your suggestion!

I tried it. When it is in STEP format, geometry faults appear when I import it to simscale.

I also tried to use other meshers and I found out that the only mesher that fails on this particular geometry is the standard mesher.

However it would be way easier for me to use the standard mesher, because I have run other similar simulation using this mesher.

Do you have any other idea that could make it work?

In the project you sent above , I see the Hex dominant parametric algorithm though, not the Standard mesher. Is it possible that you included the wrong project link?

The link of the project, in which I have the problem is this one: https://www.simscale.com/projects/miltos980/clc_flow/
(It is the fist link on my initial post)

The second link that I posted, refers to a project where I had successfully meshed the same human CAD with the Hex dominant parametric algorithm.

1 Like

I would like to inform that I have solved the problem.

I deleted and I redesigned a part of the geometry and the standard mesher finally worked.

1 Like

Hi Miltos, eliminating the geometry fault seems to be working better for these cases indeed :slight_smile: What part did you redesign, the torso?

Yes exactly.
There was a cavity inside the torso model, which caused the problem with the standard mesher.
So I cut this part and then refilled the area and it finally worked.

1 Like