Mesh error

Dear All,

Please help me with my project as link attach : “SimScale Login

This is the error notification I received.
The meshing failed on the following entities: [edge1296@Flow region]. The exact position is printed at the end of the Meshing Log.

When I try to change Mesh Setting (Advanced Setting), I still get the same notification but on different entities This error makes me waste time and CH.

Even if I change the CAD and not put Flow Region on the design (Motor area) like on this design “SimScale Login”,
but the error is same notification “The meshing failed on the following entities: [edge8281@Flow region]). The exact position is printed at the end of the Meshing Log.”

This error points to the edge near the cooling pipe (I don’t put Flow region inside of this pipe).

Please help me.

Best regards,

Hi rhezA,
The links you provided to locate your project didn’t work, but I did find your Dashboard of projects but didn’t find the failed project, maybe you could provide this shortly, but here are a few brief comments.

For me as a novice Simscale user, this sort of error usually comes with an exact location x,y,z coordinate. I see that there is a reference in your error message “at the end of the Meshing Log”

Maybe you know this already… but I create a ‘Point’ Geometry Primitives using the error coordinate to exactly locate the issue, but again I am not an expert, but this has allowed me to find exactly if it is that adjacent flow mesh or the quality of the surface mesh on the object.

image

I did notice that Profile - ggiraldof - SimScale CAE Forum was recently able to pin point a radiator meshing problem using the mesh inspection tool under “Mesh quality”, but again I am not proficient in this area.

Kind regards
Ted

dear TedBurke,

Thank you for your insight. I just update the link. Please check it again and try to look it.
I just hope anyone could help me to make this project better and done.

Best regards,

Hi rhezA,
Thanks for getting back to us with the updated link.
So I’m looking at the Meshing log from your Run 1 Mesh 2, this was the reference coordinates of the problem at the bottom of the log.
image
So plug in the coordinates from the log by creating a Point primitive (Point 1) this is achieved by Clicking on the heading of the Simulation ie “Copy of Conjugate Heat Transfer”
image
then go to right hand side of the screen to create the point 1 under Geometry Primitives, as per red circle.
image
Ok, I did the above and your mesh error is precisely located here at the blue sphere/point


This indicates to me that your mesh is not possibly refined enough in this region, but I am no expert in Conjugate Heat Transfer. I am impressed with your CAD model.
I see you are running a new mesh, but its going to be courser than the original failed mesh as the setting is at 3.4 where as it was 4.5 a finer mesh.
image

So my novice experience indicates you should be going for a finer mesh, and to speed up the meshing use more cores and possibly set the Numerics setting from Manual to Automatic.

Best of luck
Regards
Ted

Hy Ted,

Thank you again for your respond. Actually I have try with the finest ones, but I still get the same notification but on another entities (another location of my straight pipe).

When I try to change number of cores but with my another CAD Models (actually same with this one, but after I check again that CAD have a wrong dimension). I use 16 cores, the meshing is finished but with a huge value of cells and nodes. I spend a lot CH for it. But I can’t use it for my simulation, bcoz for the simulation it need a big number of CH. Final note I drop it out.
That is my reason to limit it for 8 cores.

What I curious with this meshing is, most of process always stuck at 70% and after a long time of waiting I got the error notification.

BR.

Hi BR,
Thank you for your recent response,
I don’t want give you wrong information as I am not experienced enough to advise you as I dabble in CFD and not familiar with CHT.

The only thing I can think of is look at something similar that has worked, which I expect you have done. I looked for Public projects but nothing specific for your BLDC. I did come across some related simulation that worked that use Conjugate Heat Transfer. The fist project, heat exchanger was at 1.5 million cells & I did notice the second simulation had a fine mesh 7.7 million cells, normally I’m between 3 to 7million cells. Your core hours for the mesh is a lot more costly than mine for cfd. Normally for a mesh over 7.8million cell it only takes only about 2.1 core hours for 16 core machine and about 31min. The cfd simulation can then take about 60 core hours.

This person seems to have a host of experience when you look at their simulations ,so again might be worth looking at. SimScale

https://www.simscale.com/workbench/?pid=295568150244367125&mi=spec%3A488fb8a3-77f0-4b7d-a807-c4ee9aead166%2Cservice%3ASIMULATION%2Cstrategy%3A37
In cfd its typical to use refined regions to increase the fineness of the mesh by creating privatives, but I have not seen this applied in your type of simulation, but it is available.

So as I indicated earlier, I think this is for the more experienced / experts like @SBlock @dheiny or other Simscale engineers or power users to provide the advice on your simulation.

Kind regards
Ted

Another problem is coming up on my meshing setup. When I try to generate the Mesh, this notification pop up
image

I had put only 1/3 from real CAD (BLDC New Cut 1). But it still use a lot of CH including Faces and Nodes. Do yo u have any suggest ?

BR
Reza

Hello rhezA,
in regards to the mesh error this should be solved by this week.

Also, one question to further reduce the meshing time i would continue to reduce the simulation domain.

Another option might be to not simulate the outer air volume and instead use a thermal wall model.

Best regards
Sebastian

Hallo Sebastian,

I have try it as your first suggestion. But the mesh still error.

Best regards,