SimScale CAE Forum

Mapping of assignments from geometry to mesh failed - MRF


#1

Hello,

I am trying to simulate a rotating mixer inside a water container. Howewer, lately I have stumbled upon a problem I have difficulty resolving and had no issues with before. It has to do with assignign the mesh as the domain for the simulation as seen in the picture:

I would appreciate if somebody could help me with understanding why this issue has started to emerge, and primarily how to resolve it, since as it is seen in the folowing screenshot I have made numerous simulations before and this error hasn´t occured then.

P.S: Note, that all of the simulations seen in the screenshot have been made before the error started to occur somewhere a week ago.

Hence I came to presume that CAD file has nothing to do with this error, nor does the mesh since it has changed several times during those previous simulation.

If anybody could help me with this issue i would be at most grateful. The project can be found in here: https://www.simscale.com/projects/Karlo/poskus_mesala/

Karlo


#2

Hi: this is an internal simulation, but your container has two shells (posoda shel_NONE). Then you have second container also build of two shells (shel2…). This would not work, please simplify your geometry. I suggest:

  1. External container, no shells.
  2. Zone for MRF rotation, no shells.
  3. Mixer shape.

Mesh using coarse mesh first (3 M cells for such a simple mixer is an overkill), then adjust its grain following results.

Cheers,

Retsam


#3

First of all thank you for a quick response Retsam.

I have taken your advice and made a CAD Geometry without creating shells, just fully solid parts put together in assembly + geometry using the Boolean cut as mentioned by @anirudh2821998. I implemented it on my other excercise project, where I am simulating water flow through a propeller in a pipe. There, I have the same problem as I have with the mixer. The mesh doesn´t want to get assigned as the domain. There is no difference bewteen using a Boolean cut operation or going by your advice. I have also imported geometry in .sldprt, as oppose to .step file I used before, to see if that has any effect with the issue, but there was no difference there either.

These three screenshot show what is happening when i try to add the material:

image
image
image

This geometry was made by putting all three solid parts together in assembly as you suggested. Boolean cut geometry was made in the same way using the cavity function in SW.

Here is the link to the pipe rotor project: https://www.simscale.com/projects/karlo_vaje/poskus_rotirajoce_domene_mrf_v_cevi_z_rotorjem/

Anyways the problem that occurs between these two project is the same, yet both started having problems only about 1-2 weeks ago. Is the issue maybe connected to something else? I am open for any further advice that could help me.

Thank you in advance,

Karlo


#4

Hi Karlo,

I suppose you may be a victime of new automatic mesher, where boolean operations seem necessary. However, MRF zone itself does not need to have extruded void (for placing rotating impeller). You define MRF zone simply as a container around the impeller.

If the MRF zone is handled as you did, it will contain inside mesh on boundary between MRF zone and Impeller body. I never did it that way (that does not mean that it would not always work). I may have more time on my day end and if you still in trouble I will make a copy of your project and do my test on it.

Cheers,

Retsam


#5

Hi again, Karlo.

There is definitely something broken, as even if I can assign water to the pipe, when starting simulation it asks to assign material to MRF and Rotor, which was not necessary (I compare it with ’ Centrifugal Pump CFD Simulation with MRF’ project. I’m puzzled, but would need to ask support for last software updates…

Sorry,

Retsam


#6

@jousefm: I tested that Karl project (internal CFD) and clean example is here: https://www.simscale.com/projects/Retsam/karlomrftest/

Project, this time from geometry updated on OnShape in ParaSolid format, contains three solids:

Pipe with void for impeller (boolean, but it was not necessary before)
Impeller
MRF zone

Basic meshing was done.

Boundary assignments are getting complex with faces (for impeller) in pipe. Then Simulation reports “mapping of assignments from geometries failed”.

I’ve seen people reported problem with internal CFD mesh and impeller in last couple of weeks. Would you be kind enough to check what kind of modifications were implemented, causing that simulation defect, please?

Cheers,

Retsam


#7

Hi @Karlo

I can see that you have used a solid propeller for the MRF study Here is the link to my post in which I have shown the method I use to make a successful geometry to get a MRF region- Issue with assigning mesh as the domain

I have modified the CAD for you and have got a successful MRF zone(you can use the geometry but don’t use the mesh for simulation as it contain illegal cells due to lack of proper refinement)- https://www.simscale.com/workbench/?pid=8138707925386715409&mi=spec%3Afa56265f-a571-49fd-b09a-edeb9f07af0b%2Cservice%3ASIMULATION%2Cstrategy%3A8

You can also try assigning material to the mesh and unlike your previous cases it will not assign it to the CAD model.

Thanks
Ani


#8

Hi Retsam and Ani,

first of all thank both of you for taking your time and knowledge to help. Im still struggling to solve the mesh assignement as domain. @Retsam, that is exactly what I have been doing too. I have also seen a few recent posts about MRF zone meshing having issues. Same as you, I also tried importing geometry in different CAD formats as I said in previous post, with no effect as using the Boolean function and listening to your advice for new geometry. As for @anirudh2821998, I have seen the geometry that you have created. I did implement your advice you gave to anurags in my project before coming here, but to no avail. As for the copy of my project that you have created I see that there is no impeller in the mesh. How could I calculate moments/forces on the impeller and set no-slip wall boundary, as the mesh doesn`t contain it?

With regards,

Karlo


#9

@Karlo that’s why I was talking about the presence of illegal cells and the error in the generated mesh.


#10

Karlo: Support is now engaged with demo preparation and possibly spotting the MRF problem for internal CFD. A bit patience is welcome. :lizard:


#11

Karlo: there is only one way to do the work now. You left MRF intact (should have no void), but your pipe should have the void (in a shape of Impeller, by Boolean operation). Only two body should be present for meshing: pipe and MRF zone.

Please take a look at example I set (https://www.simscale.com/projects/Retsam/karlomrftest/) for Forces and Moments calculations.

Cheers,

Retsam


#12

Hi Retsam,

I am facing the same issue even after using 2 solids geometry as suggested by @anirudh2821998. MRF mesh is still not being assigned as a domain.

Did you get any solutions for this?
And
Do you have any update regarding the demo for this new meshing update?

Thanks!
Saumil Patel


#13

Hi,

Where is your project, please?


#14

Project:
https://www.simscale.com/projects/saumil_b_patel/centrifugal_pump_-_mrf/

The mesh is preliminary but it has necessary MRF zone. I am planning to improve mesh once it can be used as a domain.


#15

Please check your assumption: Your geometry has MRF zone with void inside (‘negative impeller’). This is wrong. Main geometry seems to have correct geometry, with void left by doing Boolean operation with impeller.

There is again the project to study: https://www.simscale.com/projects/Retsam/karlomrftest/.

Cheers,

Retsam


#16

Thanks for pointing out that. Actually I had used geometry from @anirudh2821998 from his project provided in one of the posts above.

I have modified the geometry and now it has a solid MRF and a solid pump volume with an impeller void. I am still not able to assign mesh as a domain. You can check my work with the same project link. Look for simulation title “Pump with Void, Solid MRF”.

Thanks!


#17

Hi,

Looks correct except that you need to assign material to your pump only. Not to MRF zone, which belongs to your pump.

Mesh is assigned to domain, so I do not understand your statement. If you have seen something like that:

MeshSet

You need to press ‘Use Mesh as Domain’.

For simulation run, as mesh is quite big, you need to put number of processors to 16.

Thanks,

Retsam


#18

I regenerated the mesh and now I can assign it as Domain. Thank you very much, Retsam. You have been really helpful!