Issues with meshing an imported STL geometry


#1

Hi everyone,

I’m having a hard time when I’m trying to mesh a custom FSAE model on SimScale and I’m in need of some help. The full car geometry is the result of me merging multiple .STLs together and creating a master .STL which corresponds to the full car. By doing so, I could upload my geometry on SimScale.

When I tried to create the mesh for my simulation, I came up with this error after the meshing was finished: “Mesh quality report could not be created due to an invalid edge with zero or negative length in the mesh.” This led me to believe that my imported geometry (the master .STL file) was not watertight. I confirmed this by using MeshLab.

After searching online, I came across this page which describes the steps of generating a 3D volume mesh from an .stl surface mesh using Gmsh. However, I’m still not able to create a watertight geometry.

Any suggestions on what else I could try? Maybe I could send the master .STL file to someone to take a look and see if a 3D volume generation is possible? Thanks in advance!


#2

Hi @pmparitakis and thanks for the detailed description of your problem!

Could you please share your project with us - the @PowerUsers_CFD and I will have a closer look at it then.

All the best!

Jousef


#3

https://www.simscale.com/projects/pmparitakis/project18_1/

Here’s an attempt.


#4

Hi @pmparitakis!

One thing I have found is that the tank behind your driver is intersecting with the monocoque.

Not sure though if that is causing the negative length or if it is any other mistake in the CAD model. Maybe @yosukegb4, @Get_Barried, @vgon_alves and @pfernandez can help you out and identify any other CAD related problems.

All the best!

Jousef


#5

Thanks for the suggestion @jousefm!

I meshed the geometry without the intake this time but I’m getting the same error.

https://www.simscale.com/workbench/?pid=302770064029353284#tab_0-0


#6

Hi @pmparitakis, does this affect your simulation? If not I might be tempted to just accept that we have no report, the last readout from the log says that nothing fell short of the quality requirements.

Kind regards,
Darren


#7

Hi @1318980, while the simulation runs okay, I’m not sure if the results are 100% correct because of the lack of report. I’ve yet to correlate the results with the results I get from other software.


#8

Hi @pmparitakis, I think results are clearly wrong from your last run. With forces in the millions and velocity values in 1000’s in some places. Have you tried running with default numerics? I noticed you have used a lot of cell limited schemes?

Kind regards,
Darren


#9

Hi @1318980, I ran a new simulation yesterday without the intake and without rotating wall velocity because I believe that’s where the problem is.

Here’s the link to the new project - https://www.simscale.com/projects/pmparitakis/project18_2/


#10

Ah yes, they look much more realistic. Let me know how your result comparison goes, thanks @pmparitakis


#11

Will do @1318980, thanks again!