I still get the message "An error appeared while allocating memory." no matter what I do

Hello everyone!

I am currently working on a simulation of a hollow tube that will serve as a connection for an axis, where it will be applied a 300N force. A scheme for my case below:

image

My problem is that, not matter what I do, I still get the “An error appeared while allocating memory” message. I have tried the steps suggested for eliminate this error (Memory Allocation Error | CAE Documentation | SimScale), but still no progress. Aslo, my mesh is not so refined.

Since I am using the Remote Force boundary condition, I was wondering that the reason for this error may be related to the size of the face the condition is being applied on or the distance for my geometry and the reference point, but I am not sure. I cannot think of another way to set the simulation for the case that I need to study.

Could I have some guindace here? The link for my project is: SimScale.

Thanks in advance!

Hello srocketry,

thanks for sharing this case,

I’m looking at your simulation and will see how to solve this.

Best regards
Sebastian

Hello @srocketry ,

As the error message states, we either need to increase the computational resources or decrease the solution domain size. In case available resources are limited, one way to decrease the domain size is switching to first order mesh elements which are less expensive in terms of computational resources. Automatic definition currently selects a second order mesh in your application, so please change the Element Technology definition to Custom and then choose First Order. Also please change the Solver type under numerics to MUMPS again which is the default setting. You’ll see that the simulation will converge without problems. For more information please refer to the this documentation page.

Hope these are helpful,
Kaan.