SimScale CAE Forum

How to import more than one geometry (STL), to be meshed in the same project?


#1

Hi there,

I am currently trying to get into SimScale, starting with the generation of a mesh for CFD,external flows.
I would like to insert more than one geoemtry to generate my final mesh: I need the aerodynamic model, wind tunnel, cellZones, refinementBoxes. But I can’t find the way to do it. If I upload a new geometry, it seems like it’s going to create 2 separate meshes.

Furthermore, is it possible to assign different meshing features (refinement levels, number of layers) for each PID on the model??

Thank you very much.
Daniele


No connectivity Mesh!
#2

Hi @DanieleObiso,

wind tunnel meshing, generation of cell zones (I guess for a rotating region?) and using boxes for local refinement is supported in the “Hex-dominant parametric” mesh operation. What’s not supported as of now is the combination of multiple STLs within SimScale. But the easiest way to achieve that is to merge your STLs before uploading them. If you’re using linux, simply hit

cat file1.stl file2.stl file3.stl > combinedFile.stl

and upload the combined file. Single solids will be detected and you’ll be able to use them for assignment purposes.

Hope that helps!

Best,

David


#3

Hi David,

thank you very much. I will merge them.
What about the last question? How can I differentiate the meshing parameters for each PID?

Daniele


#4

Hi Daniele,

yes, you can assign different local refinement types (surface, region, feature, layers) and control all their properties locally per face. Not quite sure though what you mean with PID - patch ID?

Best,

David


#5

Yes exactly, but I found out how to manage it.

Just a short question: I generated the mesh, and the process is finished (I can see the log file). However the job is still running/computing, and I cannot visualize the mesh (it’s already 30 min after). Is there some transfer job after the runs?

Daniele


#6

Hi @DanieleObiso,

yes, there is some post-processing with the mesh happening after the actual mesh generation is done (visualization, quality analysis, persistence etc.) - that can take some time if the mesh is very large but 30 min sounds very long. If you can see the log, how many cells were generated?

Best,

David


#7

Hi @DanieleObiso,

did you try to reload your project? It works sometimes for me.

Best,
Andrzej


#8

@dheiny,
the model is not so big, 4.5e06 cells.

@akosior
I tried to reload, but it doesn’t work.

I will wait some time more.
Daniele


#9

@DanieleObiso,

5 million cells should be a breeze, so that can’t be the reason. Is it a public project by any chance?

Best,

David


#10

The run is now ended.
But looking to results, I am not so happy. It seems that snappy and layer were not processed.
Yes, you can look for my name. it’s a small project for an application process by SimScale.

Daniele


#11

Ah - that one?

I think you already deleted the old mesh, right? For “debugging” purposes I typically simply duplicate the setup, tweak and run again - that way you can review old meshes.

I’ll give it a shot myself.

Best,

David


#12

Thank you.
But slowly I am going to get it. I am used to OpenFOAM dictionaries and a GUI needs time :grin:

Thanks for support.
Daniele


#13

Gave it a little spin:


#14

Hi,

I have the same problem with the geometry and i do not know how to upload a model made of different STL files. I do not have linux so is there any other way to make it?

Thank you.
Enrique


#15

Hi @endeesto !

You can have a look at this thread F1 Session - Merging STL files

@Akrem explains in detail what you have to do if you do not have a linux distribution on your machine.

Tell me if that helped!

Good luck and happy SimScaling!

Jousef


#16

Hii!
Thanks for the video it was really helpful but I still have some small problems. I do not understand how he merges the files. I have all the .stl files of my model but i do not understand the way he merges them into a one single file. In the video it is shown in the minute 1:41:10 if i am correct and that is the way to merge the files.
What text editor can I use to do it because the one i have doesn’t work

Thanks for the help in advance
Enrique


#17

Hi Enrique,

Notepad ++ should work, you can download it at the link below:

https://notepad-plus-plus.org/

There are step-by-step instructions if you scroll down through the tutorial. Let me know if that helps.

Best,
Anna


#18

Hi Anna,
What format do I have to export binary or ASCII? because the ASCII changes the piece and the binary makes problems with the Notepad++.

Thanks for the help
Enrique


#19

Hi @endeesto,

As mentioned by @AnnaFless it is all written in the thread posted by me. There is also explained that you have to use the ASCII format.

Let me know how it goes :wink:

Cheers,

Jousef


#20

Hi
Thank you for your quick answers. I have done exactly as the tutorial and when I tried to upload it gave me an error. This is the project:
https://www.simscale.com/workbench/?pid=679177550515253479#tab_0-0

Also when I open any .stl file with my cad software that I export in ASCII format the piece is not correct and has nothing to do with the real piece. I don’t know why this can be caused.

I also tried to do it with the script of the tutorial and had exactly the same result.

Any idea where the problem can be?

Thanks for the help, sorry for the trouble.
Enrique