SimScale CAE Forum

Downloading and runing openFoam case directory in local computer gives error

Installed OpenFoam 2.3.1 (SimScale - OpenFOAM Version)

Also additionally installed swak4Foam in my local computer.

On running a case folder downloaded gives following error

–> FOAM FATAL ERROR:
incompatible dimensions for operation
[U[0 1 -2 0 0 0 0] ] == [-grad( p) [1 -2 -2 0 0 0 0] ]

From function checkMethod(const fvMatrix<Type>&, const GeometricField<Type, fvPatchField, volMesh>&)
in file /home/vishnu/OpenFOAM/OpenFOAM-2.3.1/src/finiteVolume/lnInclude/fvMatrix.C at line 1356.

FOAM aborting

#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::error::abort() at ??:?
#2 void Foam::checkMethod<Foam::Vector >(Foam::fvMatrix<Foam::Vector > const&, Foam::DimensionedField<Foam::Vector, Foam::volMesh> const&, char const*) in “/home/vishnu/OpenFOAM/OpenFOAM-2.3.1/platforms/linux64GccDPOpt/bin/simpleFoam”
#3 in “/home/vishnu/OpenFOAM/OpenFOAM-2.3.1/platforms/linux64GccDPOpt/bin/simpleFoam”
#4 in “/home/vishnu/OpenFOAM/OpenFOAM-2.3.1/platforms/linux64GccDPOpt/bin/simpleFoam”
#5 __libc_start_main in “/lib/x86_64-linux-gnu/libc.so.6”

Hi @vishnubabu_c1!

Have you tried running the case on a new(er) OF version?

Cheers!

Jousef

Yes I did that with OpenFoamV7 first
It had errors like
turbulenceProperties file not found

Tried copying from a tutorial, but still resulted in errors.

Thanks
Vishnu C

@1318980, could you give Vishnu some tips on which versions run stable and are compatible with our outputs?

Thanks and cheers,

Jousef

Hi All, you wont get any vanilla openFOAM to run a SimScale run out of the box, 2.3.1 is the closest. What you saw above is the fact that incompressible simulations in vanila openFOAM are normalised by density. as that is how it is usually solved. To make our solver more user friendly we deal with pressure as a real physical unit (Pa) and therefore when openFOAM does the check to ensure the units are correct, it finds they are not. You can simply change the units in your initial conditions in this case I believe.

Best,
Darren

2 Likes

Yes, changing the pressure unit woks. Also is the OpenFoam being used by SimScale is available to public?