Converting Simulation to Meters

The STEP model I imported and set in meters. However, when I imported the model into SimScale, it’s not in meters anymore. How can I fix this?

Hi!

Can you please share the link to your geometry so I can have a look?

Here’s a link to the project:
https://www.simscale.com/workbench/?pid=2604001352420787726&mi=spec%3A78d2559b-9f8f-4149-bea4-53273d898532%2Cservice%3ASIMULATION%2Cstrategy%3A35&ps=domain

I can see that you used STEP format.

The units in the model are written in your CAD and recognized by SimScale upon import. I would recommend you to check your export settings.

On the other hand, this can be easily fixed by using the Scale operation in the CAD mode. Scale the model up to match your desired units: