Cell Number


#1

Hi,
at the moment I’m adjusting the size of the mesh (automatic). Thereby, I noticed, that by enlarging the wind tunnel around the modell and using the same fineness, the number of cells decreased. Can someone explain me, why this happens?

Are there any tipps you can give for finding a good mesh?


#2

Thanks for your question @nils_blankenho!

Tagging @PowerUsers_CFD as well as @Anware here who might help you there. Could you share the project with us?

Generally speaking the parametric option of SnappyHexMesh is a very good choice as it also allows you to adjust different parameters. If you are interested in creating a mesh for a vehicle you can have a look at a template like the one from @pfernandez: Aerodynamic Analysis or at tutorials in the documentation Meshing Tutorials Overview.

All the best!

Jousef


#3

Hi @nils_blankenho!

This is quite a peculiar issue as running my own projects I encountered this as well. I suspect this is more to do with the “automatic” portion of the meshing parameters. By increasing the bounding box and having a fixed level of fineness, the mesher tries to maintain that level of fineness despite the larger computational space, and it can only do that by dropping the quality of the mesh for any geometry within that space and at the same time increasing the overall cell size of the bounding box. Hence you will see a decrease in nodes as the overall “quality” of the mesh is diminished and limited by the fineness level selected. At least, that’s what I garner from my own investigation.

The earlier explanation goes nicely into how to get a better mesh. Due to the “automatic” nature of that setting, you lose a lot of control over what you want to refine, how much to refine and any other optimization routines that would give you a better quality mesh while decreasing computational cost. To get a better mesh quality you should move on to “Hex-Dominant Parametric”, which Jousef has recommended earlier, where again as mentioned you have greater control over what you want to mesh and how fine the mesh is. Jousef again has kindly pasted the link on meshing which will help you understand the different meshing parameters and what they do. A good mesh in general should give you relatively good accuracy without needing you to take a very long time to compute. Hence the need for validation, which is to compare simulated data against experimental or theoretical data.

It would be easier to understand this by doing a project so please do link your project here and we can work on it!

Hope this helps!

Regards,
Barry


#4

Ok, our teacher gave us a manual to use “Hex Dominant Parametric” in case the automatic option doesn’t work (in fact it does, but I was not happy with the size), so I also tried this, but after a few seconds of computation, the program cancelled it. There is no meshing log and other entries, why it didn’t work

The link of the project is: https://www.simscale.com/projects/nils_blankenho/rc_car_drag/
The manual attempt is called “manual”

It would be great, if you could tell me, what I did wrong and also have a look on the automatic mesh I made, and say if think it is appropriate


#5

Hi @nils_blankenho,

I believe you need to do additional refinements for both your Cartesian Boxes. These can be done under Mesh Refinements > Region Refinements where you can then select your Cartesian boxes.

For the automatic mesh of rccav4 and rccav3, it looks alright and there are no significant distortions. The mesh quality check passed as well so those should be good to go.

For Mesh Formula, there seems to also not be significant distortion or illegal cells but the mesh quality check did not pass so I wouldn’t recommend using that particular mesh.

Regards,
Barry