SimScale CAE Forum

Can't upload Geometry


#1

I have tried multiple times to upload a STP file. I have uploaded it to other projects but can’t upload it to Simscale. I get an error “Unsuccessful server response code of: 500”.

Thoughts?


#2

Hi,

I´m having the same problem. Did you find out a fix for it?

Cheers,

RK


#3

HI @dhamilton and @rkuhn,

I tried to upload a STEP file three times. Once, when I created a Project I added the Step file and it said it was succesfull but when I opened up the project there was no geometry. Once from within the project I uploaded a STEP file with the same results and once it gave me an error.

Hopefully Simscale support will be able to look into this soon.

Christopher


#4

Me too dude! :frowning:


#5

I need this for homework, so I hope this gets fixed as soon as posible


#6

i have tried:
step and stl files
deleting the project and starting over
uploading file that works in different simscale file
using letters first in file name
using all lowercase

i can’t think what else to try.
this was working at earlier and then just quit.


#8

Sorry that you’re experiencing issues with the platform. Our back-end team is looking into it and is trying to fix it as soon as possible! Apologies for the lost productivity and the hassle on your end! I’ll get back to you once it’s fixed.

David


#10

The issue has been identified and resolved, all uploads should work again as before. Let me know if you experience any other issues. My apologies for the incident and the lost time on your end!

All the best,

David


#11

Its Working !!! Thanks for the help.


#12

Unfortunately I am still facing the same problem.


#13

I also have the same problem now.
In case upload from my folder occur error code 500.
In case import from OnShape data, model was imported but can’t identified in geometry…


#14

Hi @RGarcia, @ytohi,

sorry for any interruption of your work. The back-end team is looking into it as I write. Will get back to you shortly.

Best,

David


#15

Hey everyone!

I’m Anatol and responsible for what we call Platform Engineering at SimScale - that is, everything related to the platfom that underlies SimScale: data storage, executing jobs, getting data from and to your browser etc.

We recently replaced a critical part of our system, the long-term storage of customer data, with a new component that will allow us to scale pretty much indefinitely in terms of storage. We tested that component for several weeks on several development systems, but obviously some issues that are now appearing at the scale of our production system were not found by those tests. This is why uploads were failing and currently are again.

Yesterday, we thought we had a workaround for what is happening to uploads, but it seems like that was not enough. We will be working on a proper fix and let you know once we are confident we have found and properly fixed the issue. Until then, we can resolve the issue temporarily whenever it arises, and will do so (I just did that and it works again).

Best,
Anatol


#16

No Problem. Yall do great work.


#17

Thanks for the kind words!

Actually already on Friday, we released something that should make this more stable, and so far it’s looking good. We will continue to improve this part of the system however (not just stability, but also speed).

Thanks again for the patience - and letting us know when something doesn’t work! This is important to us.

Anatol


#18

Sorry Anatol, unfortunately I’m now getting this back from the server when trying to upload a step file:

… Unsuccessful server response code of: 500

Tried .step files that were previously fine to upload and getting same error.


#19

Since server-maintance a few hours ago, I’ve the same problem. I can’t upload new .step files or old files that already worked.


#20

Hello @twagner and @Jonathan_QX,

thank you for reporting this, we are aware of the issue. Sorry for the inconvenience. We will keep you updated!

Best Alex


#21

Hey everyone!

Sorry this happened again - it was the same component, behaving badly in a different way than before. We could resolve the problem again temporarily (around 2:45 PM CEST/8:45 AM EDT), but another root-cause fix will be required.

We will improve our monitoring of this component to detect this failure mode, too, and let you know as soon as we are convinced we have a permanent solution.


#22

Geometry upload is not working.

I have tried numerous times. I’ve tried creating a new project and I’ve tried with geometry I know has worked in the past.