SimScale CAE Forum

Boundary condition seems violated

I am simulating a laminar flow of air in a pipeline (Under Incompressible 3)

The boundary condition is inlet pressure ~17 Pa. However, in Run 3 (transient), after 0.4s of running, the color of the inlet is light orange (smaller than 17 Pa), while it should be red (~17 Pa).

If you look at Run 2 (steady state), after 10s the inlet pressure is still red (~17 Pa), which I think agrees to the boundary condition.

Am I doing anything wrong?

Project link: SimScale

Hey there,

Could you please try the simulation by ramping up the inlet pressure and not applying it suddenly? I suspect that some pressure wave might be created and affect the pressure values upstream.

Other things you can try:

  • Extend the inlet and outlets, this is a short pipe in relation to the diameter.
  • Switch to a velocity inlet condition, if you know the flowrate.
1 Like

Dear @yapabox589, did you check my reply here: Gas seems to flow backward? - #2 by jairogut?

In the transient simulation, you are using a total pressure B.C. In my other post I explained the way this B.C works. Your project link does not include a steady-state simulation, so I can’t verify the B.C you are using. The pressure observed in the postprocessing fields is not the total pressure, therefore the B.C is not being violated.


Thanks @jairogut for noticing and the link!


Thanks all. I changed the BC from velocity total pressure to velocity inlet. Then something surprising happened.


Those dark blue spots suggested that pressure decreases apruptly, which doesn’t seem to make sense. This is taken 0.012s after the simulation runs. What might be the cause of that?

This is the run named inlet velo instead of inlet pressure (last run)

Some other questions // comments.

  1. Why do you set a manual relaxation for the PIMPLE algorithm? Initial timesteps may require a large number of outer correctors, specially if you are initializing using a 0 z velocity.
  2. Make sure the Courant number in your initial time-step (you are setting like 0.002 s) is well under 1.0. I am aware you set a maximum Co = 0.5 but I am talking about the first timestep. For the solver, it may take a number of iterations to decrease the timestep and comply with your Co-max. The best thing you can do is manually calculate the timestep considering the size of the elements around the inlet and your maxCo value. I am positive this will result in a lower timestep. Not doing (1) and (2) may cause strong oscillations (pressure).
1 Like

By the way, you did not have to modify the boundary condition as it was working well. My comment was directed to the interpretation of the results.

1 Like

Are you talking about this?

If yes, is this a guide about manual calculation? The CFL Condition and How to Choose Your Timestep Size | SimScale, I would like to make sure I dig into the right thing.