Automatic Time-Stepping Error


I am doing a static non-linear analysis on a single body. It is meant to be a simulation of a simple-tension test on a thin strip of hyperelastic material, with a Fixed Support applied on one end and a force applied on the other. However I have had no luck in getting this to work, as I keep getting the error message “Automatic time-stepping lead to a time-step below the minimum threshold”. Here is the project link: SimScale

The advice given on the error page Error: Automatic Time-Stepping Can Not Be Calculated | SimScale says this is related to a lack of Newton convergence, so I also followed the advice given on Error: Newton Convergence Could Not Be Reached | SimScale .

I have tried:

  • Ramping the load with a formula
  • Checking the mesh quality. According to the meshing log, tetEdgeRatio max is about 2.8, triMaxAngle max is about 117, volumeRatio max is about 3.5, nonOrthogonality max is about 58, and aspectRatio max is about 2. The mesh visibly looks very fine and there is a Gap Refinement Factor of 2 (I also tried a Gap Refinement Factor of 3 which gives the same error, but this takes alot of resources so changed it back to 2).
  • Increasing the tolerance of the convergence criteria to 1e-3
  • Increasing Maximum Newton Iterations to 30
  • Changed the convergence criteria to Absolute
  • Decreased the Minimum Time Step Length to 1e-7 (I have even tried down to 1e-12 but the simulation was taking too long to give any result).

I also followed the advice on Modeling Elastomers Using FEM: Do's and Dont's | SimScale Blog , which suggests using 2nd Order elements for thin structures and with very large deformations, and using Reduced Integration for nearly incompressible materials. Lastly I tried using a Fixed Value displacement instead of a Force boundary condition as suggested, 0.001m statically applied and also ramped, but the simulation was taking too long to give any result.

Hi there, it seems your final simulations did not give that error. What did you change? :slight_smile:

Best regards,

Hi Filia, I just changed the Force boundary condition to Fixed Value displacement, but I cancelled those simulations because they were taking too long.

1 Like

I don’t yet have a solution to this problem, I clicked Solution by mistake.


I know this is an old topic, but I was able to run the simulation:

I performed many changes, but what I think that made it run is the material properties.


Thanks ggiraldof! I’ll be looking into this…

1 Like