SimScale CAE Forum

Autodesk inventor format does not import

Having issues importing geometry from Autodesk inventor 2022.

File saves as assembly, zipped into a folder and dragged in. File imports perfectly when exported as Parasolid.

Please advise on why this doesn’t work.

Error Code: 40bdb6f9

Hi, this is Fillia. So you are facing an issue when the model is uploaded as an assembly, right?

Correct. I have zipped all the assembly files into a single folder then uploaded to SimScale using a packandgo from Inventor.

The zip file contains only the assembly file and the parts contained within that assembly.

Hi,

Does the assembly contain more than 1 .iam files? If so, have you already tried to name the zip file with the same name as the master assembly?

Furthermore, have you already tried using the Pack and Go functionality to export your assembly from Inventor instead of doing that manually?

Since the file imports just fine as a Parasolid model, there is likely something wrong with how you are handling the assembly zip file.

Cheers

Hi Ricardo, I zipped using the Pack and Go function from Inventor :slight_smile:

It looks like this does work when the filename of the zip file matches the filename of the assembly. This seems to be the trick.

It displays a warning message on import, but otherwise this seems to have fixed it:

" The import scope was determined using the first alphabetically sorted assembly file, which might result in a loss of parts if the first assembly was not the root assembly. Please ensure the desired parts were imported. For more information about the assembly import, please look at the documentation."