SimScale CAE Forum

Animation is not working

HI,

I posted yesterday about an impact test I am trying to simulate of a portable charger I have designed. I have input an object that the charger should be hitting off in the animation although it doesnt seem to be happening.

Also the stress is being shown across the ground rather than the charger which is where i want to see the stress graphs.

Any help would be greatly appreciated!

here is a link to my project
portable charger simulation | SimScale Workbench

1 Like

Thank you for sharing! I see that only one timestep was written before the simulation finishes, so I will check and be back as soon as possible :slight_smile:

1 Like

Hi, I am not really sure how to change this ? Is there nay chance you would be able to show me ?

Update:

  1. The initial velocity is directed towards the positive z-direction, which is the wrong way. You can try to use -4.85 m/sec instead

  2. If your end time is 0.01, the body will not have enough time to cover the distance with this speed. Try the manual time step definition, with a Simulation interval of 0.02 sec, and the following timestep lengths:

Check this article too:

Best regards,
Fillia

2 Likes

Hi Fillia,

Thanks for the feedback!

I have tried making these changes but the charger still isn’t reaching the ground and making contact ?

Really unsure how to get this working?

Calum

Hey, the global initial velocity should be 0, and the subdomains’ Uz should be negative:

Can you make these changes, and let me know how it went? :smiley:

Best regards,
Fillia

Okay great, will try this and let you know how it goes !

Thanks

1 Like

Hi,

The simulation seems to be working now. The only problem is that it isn’t showing any stress distribution.
I am unsure if this is a software problem or whether the impact actually isn’t producing that much stress in on the model.

Calum

I am happy to hear that it works now :slight_smile: Can you also provide a screenshot so I can check the post-processing settings you are using please?

I also just tried to increase the velocity of the part by 10 to see if a higher impact force would create more obvious results but this error occurred.

I checked run ‘ABS from 1.2’ . Using the isovolumes method, you can locate the parts of the model that have really high stress values. As a result, the rest of them are colored in blue (check this issue here, it is similar: Pressure reading and colouring problem)