SimScale CAE Forum

Unknown Error in Multiphase Flow

I’m trying to copy a public project on Simscale with a different geometry type and running into errors. My geometry is more complex but I’m using the same values. I think the problem lies in meshing or numerics both of which I am struggling at. Can anyone please take a look and help?

Original Edited Project Link
https://www.simscale.com/projects/shamshx/rising_bubble_in_a_liquid_domain_-_multiphase_flow/

Where I am getting errors on?
https://www.simscale.com/projects/shamshx/go_get_it/

Thanking you in advance.

@CFD-SQUAD, could you have a look at the project(s) from @shamshx and see if you can find a setup issue? Will jump in asap.

Cheers!

Jousef

Thank you. Any help will be most appreciated.

Hey!

I had a look at the set up. Multiphase analysis definitely needs more attention during the set up. Make sure to review your initial conditions, they seem to be inverted:
In your set up, water is associated with phase 1:

So right now, you’re initializing the entire domain with phase 0, except this small bubble, which is being initialized as water. I guess it should be the other way around:

The mesh is also tricky. To make the analysis cost-effective, it’s important to keep the mesh as coarse and uniform, if possible.
As a personal preference, I like to use the hex-dominant parametric (it takes some practice to use it though!).

With that being said, would it be possible for you to slightly change the geometry? I believe these pointy corners won’t play a massive role in terms of results, but it will be a little more difficult to achieve a coarse mesh. If you make their tips a rectangle instead, it would help a little bit:
image

Cheers

Thank you for the reply.

Yes I am trying to visualize a Water droplet going through this geometry which initially has air only. I can try using a coarser mesh and slightly change the geometry.

Do you think the numerics or solution controls also need to be changed? I’m not exactly sure as to what solvers to use. So I am following the ones in the public project link provided above.

Edit:
https://www.simscale.com/projects/shamshx/go_get_it_2/

I’ve changed the geometry.

Have a look at this. I tried Hex Dominant mesh but was getting errors so I switched to Tet Dominant. Still no luck.

If I know that my model setup, numerics and solution controls are right then I will start playing with meshing only.

@jousefm, @CFD-SQUAD and @Ricardopg

Okay so I have created multiple geometries by now. I think the major issue is meshing here and I don’t know how to get square elements like in the sample project.

Please have a look at these:

Sample Project: https://www.simscale.com/projects/shamshx/rising_bubble_in_a_liquid_domain_-_multiphase_flow/

My Tries (Using same numerics and settings) after the recommendations posted above.
https://www.simscale.com/projects/shamshx/go_get_it_3/

https://www.simscale.com/projects/shamshx/go_get_it_-straight-/

All solutions terminate after 4 mins and end up in an unknown error.

Hey!

I got a stable version of it running here. I’m afraid there’s still some mesh/numerics optimization left to do. Currently the timesteps allowed are quite small, due to the mesh size.

And about the errors you were getting: they were most likely linked to this parameter:

Since the mesh cells are VERY small (given the overall domain size), the initial timestep has to be very small as well. If you prescribe e.g. 1e-3 seconds, this will cause a major jump in the Courant number, leading to a divergence right off the bat.

Anyways, going forward, I believe you should try to get an optimized mesh (with bigger cells, to lower the cell count). This will allow a faster simulation runtime. Some tweaking on numerics can also help (e.g. I reckon I added more “number of outer correctors” and “number of correctors” than necessary).

1 Like

Thank you so much!

This looks like a thing that has at least started my simulations. I’ll give it a few runs and update you after which I’ll go on to the changing in numerics.

1 Like