SimScale CAE Forum

Unable to change mesh precision setting

No takers?

what drives ‘Maximum precision of model and its entities: 0.003483937174740073 m’, in the meshing log? my auto fineness setting is at 6.4 and I expected a much lower element size. the resultant mesh is too coarse. I am unable to drive this any lower despite manual settings and regional refinement. These were all ignored because of this 0.003m ceiling.

This is what’s reported in meshing log:

Maximum precision of model and its entities: 0.003483937174740073 m.

Absolute small feature tolerance: 1e-05 m.

Gap refinement size is reaching lower cell size cap for 2 faces. Consider lowering model tolerance if resulting mesh fineness is too coarse.

Gap refinement size is reaching lower cell size cap for 1 regions. Consider lowering model tolerance if resulting mesh fineness is too coarse.

Determined sizing is reaching lower cell size cap for 2 faces. Consider lowering model tolerance if resulting mesh fineness is too coarse.

Region refinement size is reaching lower cell size cap 0.034839. Consider lowering model tolerance if resulting mesh fineness is too coarse.

The successful simulation is named ‘baseline’, where meshing respected my settings and gave expected results. The new simulation is named ‘reduced exit area’. Mesh2 is the one causing the problems.
https://www.simscale.com/workbench/?pid=3858957670162828685&mi=spec%3A89d4308f-6584-4dc5-a466-8651e20eb001%2Cservice%3AMESHING%2Cstrategy%3A6&sh=5

Hi!

You can lower the meshing model tolerance under Mesh - Advanced settings - Small feature suppression:

I can see that the project has a successful mesh for both geometries, maybe you already overcame the problem?

1 Like

Hi, I will try with a lower 1e-6 tolerance setting, but I doubt it is the root cause. The meshing operation has always been successful. the only problem is that it keeps ignoring my regional refinement edge length because of this strange ‘max precision’ limit of 0.003m that I don’t recall setting myself anywhere.
My first simulation’s meshing behaved as expected. it fully respected my regional refinement edge length of 0.001m and created a dense mesh inside the cartesian box I created. The meshing log shows:

’ Maximum precision of model and its entities: 1e-05 m.

Absolute small feature tolerance: 1e-05 m.

Gap refinement size is reaching lower cell size cap for 0 faces. Consider lowering model tolerance if resulting mesh fineness is too coarse.’
which is good enough for my purposes. The problem starts with mesh 2 where most of the simulation settings are the same, only the geometry is a little different: i reduced the exterior fluid volume and changed an internal flow exit area geometry. For some reason, the meshing operation changed the max precision to 0.003 or so.

unfortunately the tolerance setting didn’t solve the problem. i stopped the meshing operation since the log already shows the same issue:

Maximum precision of model and its entities: 0.003483937174740073 m.

Absolute small feature tolerance: 1e-06 m.

Gap refinement size is reaching lower cell size cap for 2 faces. Consider lowering model tolerance if resulting mesh fineness is too coarse.

Gap refinement size is reaching lower cell size cap for 1 regions. Consider lowering model tolerance if resulting mesh fineness is too coarse.

Determined sizing is reaching lower cell size cap for 2 faces. Consider lowering model tolerance if resulting mesh fineness is too coarse.

Region refinement size is reaching lower cell size cap 0.034839. Consider lowering model tolerance if resulting mesh fineness is too coarse.

why is it 0.034839? i think this is the key.

This comes from the geometry model tolerance, and is specified by the CAD program.

Because of numerical limitations, you can see that the mesh algorithm tolerance is 10x the CAD tolerance.

A solution to this would be to go to your CAD and try to manage the IGES export tolerances. Maybe switch to native format (PARASOLID) or STEP might help.

1 Like

thanks. like many others I use Fusion 360 under a personal license. There doesn’t appear to be any setting when exporting IGES (they are going to remove this function soon I heard). Strange thing is when I exported a larger fluid volume for the first simulation, the precision was much finer and met my meshing needs perfectly. I will report back if STEP works better.

1 Like