SimScale CAE Forum

Transient CFD Simulation controls



I am trying to iron out the issues with a simulation I am running analyzing different ship hull designs I have come up with. I am new to CFD and this has been quite the learning experience. I finally got the project to work well utilizing a symmetric hull design and setting the mesh refinements to line up with correctly with the water line. (I was getting a wave at 0 sec). However I am now at the point where I want the model to reach steady state but it is taking forever to get to that point and causing the simulation run time to be far longer than I would expect. I want to see the entire wave pattern and get total resistance on the hull and I get part of the way there but I feel it needs about 3 to 4 times more run time to get into steady state. I copied an existing project and modified it to be compliant with my model. When I use their Simulation control settings, my sim result (wave pattern, forces) is only a fraction of what the copy is. They used a scale model where I used real life scale, so is that it? I didn’t think scale had much to do with it as it’s just a difference of units. Here is my project:

Here is the copy:


Hi @z61design and thanks for the detailed description of your project!

I will have a look at this later on and tagging my colleagues @Get_Barried and @1318980 here who might give you some additional input on your setup.

Keeping you up-to-date!



@jousefm Great! Looking forward to some feedback.


Hi @z61design!

The simulation you are running at the moment is transient and takes not as long as the previous one, has anything changed so far and could you identify troubles in your simulation setup? Have you run a steady-state simulation and could see some oscillations of drag (or any other output) or the residuals? If so then the phenomenon involved is transient otherwise steady-state. My advice would be to always run a steady-state simulation first to see some unsteadiness in the plots and then decide if a transient run makes sense or is indeed necessary.





It’s not taking as long because I reduced the delta t, however the results were worse then from before.

My understanding is that multiphase analysis has to be transient, is that correct? There is no option to analyze the simulation I started in steady state. Or do I change the time start to say t=90 sec?


Hi @z61design!

Depends on the phenomena as I mentioned but as you can see the multiphase option only allows transient in the main option however there is a “hidden” feature for multiphase flows allowing steady-state runs with so called local time stepping (LTS) - convergence to steady-state is excellent in most of the cases. The algorithm first maximizes the time step comparing it with the local CFL number and then processes the time step field and then “smoothes” the field by varying the time step to avoid instabilities.

So to answer your question I would use this approach as several simulations for 6 DOF have been performed with this LTS and were very successful reaching steady-state quite fast. Let’s try that one I would say :slight_smile:





I had LTS selected already, but the option for transient is still greyed out. Is there something I am missing? Or does it do that automatically?


Hi @z61design!

Sorry for the late response. So, to wrap things up for LTS you use local Euler - a small summary of the settings for the time differentiation:

  • steadyState: sets time derivatives to zero.
  • Euler: transient, first order implicit, bounded.
  • backward: transient, second order implicit, potentially unbounded.
  • localEuler: pseudo transient for accelerating a solution to steady-state using local-time stepping; first order implicit.

Here you can find more information:

Let me know if you have any further questions.




I really appreciate the help, unfortunately I am completely lost on what you are describing and in trying to find this hidden feature. I understand the concept somewhat but I can’t find any documentation on the process in SimScale. I’ve have searched the forums to see how to change the scheme to localEuler. I can only assume that it is already doing it for me since I have LTS selected. I’m still really new to CFD (Only maybe 20 hours on ANSYS before using SimScale?) and have never used OpenFoam. I still thank you for the time you have given, I just hope my hours don’t run out during this last sim.


Hi @z61design!

So you can find it under Numerics and go to Schemes (see picture below).

If you have troubles with core hours no worries I can add a few to your account :slight_smile:

Cheers and let me know if the answer helped you!




Yes that did! Thanks, but it was already selected I guess from the previous project I had copied. The simulation I am running now looks to be getting good data, but it’s been 24 hours already and it’s only at 28%. I may have to just wait it out a few more days. It’s just seems odd to me because the sim times from the project were so much lower that I thought I did something wrong.


Hey @z61design!

No worries. If time is short or you might run out of core hours I can run the sim for you on more cores and share it with you afterwards. You could run small test cases to see if they match your expectations and if so share them with me - I will take care of the rest.





Do you mind running it for me? I’m still only at 57% two days later. Or adding more hours. I wanted to run more iterations of the design if possible


Sure @z61design!

If you are confident that your project is properly set up you can share the latest version with me - will also countercheck beforehand.





Here is the link:

Use the Design 1 simulation.

I think it will solve fine but I think the last one failed (Run 7) because I exceeded my allotted hours. Nina had emailed me about trying professional for a week, but haven’t heard back from her.


No worries @z61design ,

will give it a spin now. Keeping you up-to-date!



Finished! Took an enormous amount of time to finish this, wow. . . :slight_smile: Let me know what you think - shared it with you.




@jousefm Thanks!

Yes, that what I was trying to figure out. Do you think it was because it was a full scale model? (The ship is 190 M long) That’s the only thing I can think that would have been different from the project I copied as their model was on a much smaller scale.


Hi there!

I would rather say that the long simulation time with 20 seconds and the fine mesh are the cause. For future runs I would say go down to <1 million cells (maybe even 500,000) and less than 20 seconds.