Thermomechanical Simulation: Using more than 10 time-steps


#1

Hello! I’m trying to simulate thermal stress in a glass baking pan. (name: Pyrex Pan Thermal Stress Analysis II, simulation: pan_quarter_with_block)

I want to model a room-temperature pan being heated in a hot (450 K) oven, and find when and where the maximum stresses occur.

However, the default of 10 time steps is not long enough for the pan to equilibriate (to reach 450 K, or at least get close). I’ve tried changing the number of time-steps, but this doesn’t seem to be an option for thermomechanical analyses.

I also thought I could use a previous temperature distribution as a starting point for a second simulation, and chain them up that way, but I can’t enter a complex temperature gradient as an initial condition.

What do you recommend to extend this simulation?

Thank you!


#2

Hi @evargo!

@SoMe_Support and I will have a look at your project and get back to you asap.

Best,

Jousef


#3

Hi @evargo,
I guess there is a misunderstanding regarding the meaning of the items in the Simulation Control settings:
simulationTime

What you increased, was the Maximum runtime, which defines (in clock time) how long you would allow the computation to run for. After that time is surpassed the run is canceled to not waste too much of your computing quota in case a setup mistake or similar would make it run indefinitely.

The time setting which defines the transient time stepping of your simulation is defined under Timestep definition.
There the Simulation interval defines the simulation time and the time step length defines the time increments on which the system is solved . So in the example here, the heating analysis would be done for a simulated time of 300 seconds and the time steps 10s, 20s, …, 290s, 300s are computed.

I updated your model and also added a result control item so that you can see the max temperature graph to easily check convergence:

The project is this: https://www.simscale.com/projects/rszoeke/pyrex_pan_thermal_stress_analysis_ii/

Best,
Richard


#4

Thank you so much! This is perfect :slight_smile:


#5

If anyone else is struggling to control time-stepping, the controls don’t show up when I use Chrome as my browser, but do show up with Safari!


#7

Hi @evargo,
this behavior is actually very unusual. Could you add a screen shot of how the controls look for you? Could you also add some information on you OS and browser version? You can also write me the info directly on a private message.
Thank you!

Best,
Richard


#8

Once I adjusted the Simulation Control options in Safari, they now appear in Chrome!

Initially, I couldn’t open up the “Details” section beneath the “Timestep Definition” header. That no longer seems to be a problem, though, so I’m not sure what was going on!