SimScale CAE Forum

Sudden Floating point exception Mesh Error



I have been running a series of simulations with the exact same settings and minor geometry alterations in the past week. However, for some reason, the last couple have been giving me a “floating mesh” error. Can you please tell me why this is and how I can fix it?




Hi Tina!

Before I delve deeper into your project, have a look at this post from my colleague Johannes: Most Popular Errors of Simulation - let me know if that helped. Otherwise the PowerUsers and me can jump back in and help you out :slight_smile:





I’ve been running some tests meanwhile. This error message is not a common one, first time stumbling upon it.

There was one post with a similar error message in the past, although it was while a simulation was running, and not while the mesh was being generated.

In any case, I noticed that there’s a decent number of mesh faces in error just before the script crashes:

Now I’m really not sure what causes this error but I tried to use a little bit extra refinement in hopes of getting less bad cells.

I ended up managing to get a mesh by changing region refinement from level 3 to level 4 and by disabling min volume in mesh quality controls:
Here’s the final lines of the log from the resulting mesh:



I think Ric has given you about the best answer you will get on this one :wink: (That topic of mine was never resolved completely, I did what Ric did (with some effort) for you, find a way around the issue and move on…

Good job Ric!

Tina, if Ric’s answer helps you out enough to continue, you could thank him a little by marking his post as the solution to your problem by ticking that checkmark on his post.


Thanks for the insight Ricardo! Already marked it as the solution :slight_smile:




Thanks a lot guys! Problem solved!