SimScale CAE Forum

Step-by-Step Tutorial: Homework of Session 2


#91

I have exactly the same problem with my mesh. Remeshing and Deleting the former mesh didn´t solved the problem. What can i do?
Thanks for your help!


#92

This seems to be the case. They changed the names of the variables as snappyHexMesh reads them to something more human readable. The relative position withing the GUI seems to be kept, so you may infer which is which from the snapshots and their meaning.


#93

Hi, I have a real problem to set my mesh because every important label at me means something else than in the tutorial. Can someone help me?


#94

Hi,

I also have the same problem as “zplocke” and “PNtakos”.
I hope you can help.


#95

Hello @hgibbons, @fkarl,

the labels come within an update of the mesh operations which provides more easily understandable labels and improved help texts. As online-platform we try to deploy improvements as fast as possible to the live system.
In this case it was not synched with the homework definition for the workshop which of course makes it very hard for you to follow the tutorial. We will re-enable the old labels again until the homework is done and deploy this improvement later this week. We will also have updated homework instructions for session 3 at that point!

We apologize for the inconvenience,

Best Alex


#96

@afischer When should we expect that roll-back so we can start working on the 2nd homework? Thank you.


#97

Thank you very much for your help, do I need to do anything further?

Harry


#98

Hey @PNtakos,

we updated the mesh operation labels 1 minute ago. I double checked, so you should see the old labels again that fit to the homework instruction. @hgibbons, you do not need to clean cache or sth. else.

Sorry again for the inconvenience,

Best Alex


#99

Hi,

after using the fix mentioned above for the illegal cells, my mesh Operation fails with the Message: “The machine ran out of memory. Please choose a larger machine for computation.” I have redone the operation settings and the mesh refinements multiple times to make sure all the values are correct, but it produces the error every time i try to mesh.
What can i do to fix this?
(Project link: https://www.simscale.com/workbench?publiclink=22dd9a71-dcdf-4c16-b44b-8453156b4470)
Thanks in advance.


#100

Hi Mjunk,

There are some warnings about illegal triangles after surface tesselation and some other issues with the geometry in general. As you created this project 4 days ago, you most likely have not the latest version of the geometry. Import the Homework Project again from the first post and you should be good to go.

Cheers,


#101

I have already completed a simulation with wrong results due to bad mesh quality.
Do I need to redo the homework for correct results?


#102

@Milad_Mafi @Akrem @ahmedhussain18


#103

Hi,

If you have run the simulation with the older mesh for End Time = 6,000 (See section ‘Simulation Control’), then your results should be fine and you can submit. This is because the older mesh requires more iteration to converge due to bad quality . If not, then you could change End Time to 6,000 (for the same mesh) and start a new Run .
Or alternatively, re-do the mesh and run the simulation for End Time =1500 with new mesh.

So which ever you feel is easy.

Best,
Ali


#104

hello,

I don’t know why the meshing operation fails. I’ve tried to run the meshing operation with 32 and 16 cores.

The last lines of the “Meshing logs” are the following. Any suggest?

After refinement surface refinement iteration 6 : cells:3503108 faces:11727465 points:4788021
Cells per refinement level:
0 94266
1 834
2 3558
3 18776
4 80389
5 419103
6 1166568
7 1235630
8 483984
(11): ERROR: dgraphFold2: out of memory (3)

Primary job terminated normally, but 1 process returned
a non-zero exit code… Per user-direction, the job has been aborted.

[8] #0 Foam::error::printStack(Foam::Ostream&)[9] #0 Foam::error::printStack(Foam::Ostream&)[10] #0 Foam::error::printStack(Foam::Ostream&)--------------------------------------------------------------------------
mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:
Process name: [[17949,1],11]
Exit code: 1


#105

Dear SimScale team,

while working I got the following message:
‘Cannot fetch results.Error code f5tywkhm.’


#106

@Ali_Arafat I tried to rerun the simulation with end time = 6000 but it has been cancelled and it stops at 2800 sec. The results are quite similar to those obtained in the tutorial. Why has the run been stopped?


#107

Hi @vlupi

Your run was cancelled because the “Maximum execution time” that was specified in Simulation Control was exceeded.
The “Maximum execution time” (which is Not the simulation end time) is the maximum real clock time for the run. It is used mainly as a safety feature to limit usage and save core hours.
In the case of this tutorial it was set to 18000 sec (i.e 300 minutes) , after which the run automatically cancels.

To run it longer just increase this value to about 42,000 sec and and rerun for End Time of 5,000 or 6,000 ( I think 5000 should be enough to get good results and full convergence). See below for details
.

Thanks for pointing this out, as it might help others also.

Best,
Ali


#108

SOLVED!:wink:


#109

https://www.simscale.com/workbench/?pid=6437182626198652855#tab_1-0

please figure out the mistake


#110

please correct my mistake too