SimScale CAE Forum

Snappy Hex Mesh - No layers?

Hi, @adidavinci @dheiny

I have created this topic to solve the issue of “snappyHexMesh not generating layer mesh” as reported by @adidavinci in project post 'Meshing Test' simulation project by adidavinci so that others with the same issue can see also.

The thing is," for ‘SnappyHexMesh’ (auto or custom) it is a requirement of the algorithm that the CAD geometry must have more than 1 Faces for each Solid ".

In the case of the above mentioned project, the Solid , ‘Tire’ has only 1 Face. I have then split the Solid ‘Tire’ into 2 Faces (can be any way, but I have done it along symmetry plane) and meshed using:

1- “SnappyHexMesh” with relative values for Layers. The result is shown below;

  • if you want to use, absolute values (Relative size: false) you must make sure the values are correct and fulfill the quality parameters

2- “Automatic Snappy hex for External flow” using settings shown below (here the ‘BaseMeshBox’ size must be defined by user):


Link to project:

So, in both cases the layers work fine and It was just the requirement of the mesher. To avoid such a thing and help users running into this issue we will add some kind of a warning in the documentation for Snappy hex mesh (also this post will help) and if possible, some kind of check on the geometry in the future.

For now, this solves the layer issue.

If you still have issues, please post here.


1 Like

@Ali_Arafat - How did you manage to split the surface, Did you do it outside of SimScale or within the platform?


not sure how @Ali_Arafat did it, but Onshape also recently added the “Split face” capability, see their documentation about it here (Image taken from the Onshape documentation):

@adidavinci To modify the geometry you can use any CAD tool ( outside of SimScale platform) or as David suggested, “OnShape”, which is free online CAD tool.