SimScale CAE Forum

Simulation Runtime Question


#1

I have been trying to simulate the flow through a tall funnel for a school project. So far i’ve had an allowable maximum runtime of 100.000 seconds. But all of the sudden i only have 30.000 s available. This means i can’t complete som of my simulation. Have already applied symmetry twice and made my mesh as small as i possibly can.
Anyone have any idea why my max runtime has been reduced? This seems to hae happended on every account. And any idea for a fix.

Project Link: https://www.simscale.com/projects/slayernator/funnel_-_300_mm_tube/

Thanks


#2

Hey @slayernator,

I noticed you’re saving quite a lot of result sets with your current write interval settings. For a 4.45 seconds time span, you have already written almost 800 sets - this slows the simulation down severely.

I know the animation is much smoother when you save a lot of sets, but maybe you can make it a little less frequent and still get a good animation.


#3

I have tried increasing my write interval tenfold but my simulation still won’t finish.


#4

By changing some parameters, namely max Courant allowed to 0.7 (it could go even a little higher) and also reducing the number of iterations for the PIMPLE algorithm, I’m running about 12% per 1h, so it should be able to finish with these settings.

.

image

.

image