Simulation problem


#1

I am trying to simulate the flow around the diffuser. I have created a mesh, which I believe was correctly build. After that a set up a simulation and after 30-45 minutes I got a response about failure. Could you please inspect what have I done wrong.

https://www.simscale.com/projects/Zaapex/tla_difo/


#2

Hi @Zaapex!

Your mesh seems alright at the moment but that might have issues lets solve the simulation issues first. Looking at your simulation you have a generally good idea on what to do so lets try to change up some of the boundary conditions to hopefully fix the I/O error.

  • Set your side and top walls close to open air as possible. I recommend setting bounding box 1, 3 and 4 type to custom with your velocity as slip and the remaining parameters as “set gradient to zero”.
  • Your material selection seems to be wrong. Did you want to have it as a custom input? If you want to simulate air but change density you can do so by importing air from the material library and then adjusting your density from there.

We’ll see how this progresses first before playing around more with the boundary conditions and if still not working moving on to the mesh itself.

Let us know how it goes!

Regards,
Barry


#3

Thank you for your recommendations but it did not work.I still got an error after 30 minutes.


#5

Hi @Zaapex, so the simulation setup to me seem solid however the mesh bears this report:

Checking faces in error :
non-orthogonality > 75 degrees : 11394
faces with face pyramid volume < 1e-13 : 6909
faces with concavity > 80 degrees : 1220
faces with skewness > 4 (internal) or 20 (boundary) : 6
faces with interpolation weights (0…1) < 0.02 : 78
faces with volume ratio of neighbour cells < 0.01 : 65
faces with face twist < 0.01 : 6142
faces on cells with determinant < 0.001 : 139
Finished meshing with 25953 illegal faces (concave, zero area or negative cell pyramid volume)
Finished meshing in = 1023.82 s.

Simply put, this need to be considerably improved to get a converging solution. The simulation performed started the first time step and then crashed meaning that it is a numeric issue we are facing here.

Things like this are causing issues:

I would say try to reduce the setting ‘Min cell volume [m³]’ = -1e+30

and see what the mesh quality turns out like before increasing quality iterations.

Good luck,
Darren


#6

Still no success. So we are trying to minimize the amount of illegal cells right?


#7

yes, that is correct @Zaapex, they are the most common cause of numerical issues, how many have you got it down too?

Kind regards,
Darren


#8

Now I am down to 23800 illegal cells.

Best regards,
Zappex