Simulation error, how do you fix the mesh refinement

  • Mesh 8
    • The mesh could not be generated as the mesh sizing is too fine. Please inspect your settings and try to reduce the fineness of your mesh or your refinement size.
      Please check the ‘Event Log’ and ‘Meshing log’ for more details.

this is the error I’m receiving when i try meshing my cad model, I have tried around ten times, please help me i have even refined the faces that need local refinement. Tell me all the meshing parameters that i can change to mesh the model better

Hi @mansi_achar, thanks for posting at our forum :slight_smile:

Could you kindly provide us with the link to your project?

That’s the link, I’ve updated the settings of the project to “share with support”.

Hi @mansi_achar,

Looking at your simulation, I see think there are three main problems:

  1. It looks like the model is self intersecting. That will make it difficult to generate a mesh:

  2. I see that you used the wrap function to close the model. While that’s an option, it may not be the best one since you’ll lose a lot in terms of resolution.

  3. You’ve set an element refinement so small compared to the model’s scale that it would be extremely difficult to generate a mesh that refined, in my evaluation:

    At the same time, for the rest of the model, you’ve se it to a really coarse refinement option:

I hope that helps :slight_smile: