Simulation does not converge


#1

Dear Support,

I need help with my project. I try to simulate my new design of a car, especially a new nose. I made a mesh which reported a small amount of illegal cells, around 90. So I was surprised to see that the simulation did not converge.

The problem occurs for simulations of FW_On_15m/s and Old_FWon_15m/s. I also stopped the simulations, after 100 minutes, when I saw in convergence plot that something is not ok.

So could you help me with that.

link: https://www.simscale.com/workbench/?pid=4143720120298681119#tab_0-0


#2

Hi @sengineering!

Let me tag my colleagues @Get_Barried and @vgon_alves here who might have a look at your project. Will also investigate this which might take some time so please be patient, we will figure this one out :wink:

Best,

Jousef


#3

Hi @sengineering,

Try disabling the “Initialize with potential flow” option under Simulation control to see if the divergence is reduced if not fixed all together.

Let me know how it goes.

Cheers.

Regards,
Barry


#4

Now simulation went better, but still the convergence plot is not ok.


CFD Simulation FSAE Car - Simulation Error at 0%
#5

Hi @sengineering,

Looking through the simulation, the only difference is the mesh at the moment. I inspected your geometry, and the first geometry meshed relatively well due to the reduced complexity despite the geometry not being waterproof. In essence, you may have gotten lucky with the first particular geometry/mesh.

For the second and third geometry, the same issue persists where the geometry is not watertight. With the added complexity of the front wing, the errors within the geometry are “magnified” and this likely translates to the mesh which gives rise to the divergence seen in your simulation.

The fix now would be to fix the geometry to ensure it is watertight and apply best CAD practices to ensure a high quality CAD model for meshing. The mesher (SnappyHexMesh) is a iterative mesher and requires a good quality, defect free geometry to build the mesh upon.

Do adjust the geometry, re-mesh and try to simulate it again. Let me know what the results are.

Cheers.

Regards,
Barry


#6

I used MeshLab to see where the geometry is not watertight. The problem is that it does not give any hint where this could be. So for now I am not able to spot what is the cause of the problem


#7

@yosukegb4, do you know if Rhino is able to visualize erroneous CAD components locally? Should be possible, right?

Cheers,

Jousef


#8

Yes, many tools…

Start with Analyze>Edge Tools>Show Edges. There you can see Naked Edges and Non-manifold edges. You can even heal (a bit of a fudge) a little with ‘Join 2 naked edges’ and more if needed…


#9

Currently I use NX Siemens 11 for CAD modelling. Do you know if I can heal this problem with my current program?


#10

Hi @sengineering,

Apologies for the delayed reply. I do not think many of us use or have access to NX for CAD modelling, you may need to seek a experienced CAD model user to get this resolved if you are unable to. My friend @jhorv_th might be able to give you some general CAD tips on how to possibly fix your model, but otherwise you do need some outside help.

Cheers.

Regards,
Barry


#11

Hi @sengineering,

well, for the first sight it seems to me that the geometry looks pretty good for CFD! I couldn’t spot any open surface so far. I think that the error message is maybe because there are multiple seperate bodies. May you please try to connect the parts with shaft for example? Let me know if it worked. If not, I’ll have a closer look on your project! :slight_smile:

Back when I was at the uni we used Siemens’ Solid Edge but I’m not familiar with NX.

Looking forward to hear from you!

Bests,
Jani


#12

Which parts do you suggest that I connect with shaft? Rims and body?

Have a nice day


#13

Hi @sengineering,

first of all, sorry for my late reply! This week was quite offline for me.

Yes, my idea was to connect the rims with body so only one solid body is simulated.
Let me know, if it works! :slight_smile:

Bests.
Jani


#14

It worked :), but there are new issues.

Only omega does not converge, all other are fine. So maybe the issue is with cell area which is maybe somewhere to small, so I set it according to 30 +y (this is around 58e-8m2).

All best